Setup IDE for openHAB2

I am following this tutorial to setup openHAB2. After I’ve finished, a lot of bindings are showing errors. The log shows this error at the moment:

!SESSION Wed Oct 07 00:36:15 CEST 2015 -----------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2015-10-07 00:36:15.974
!MESSAGE Exception launching the Eclipse Platform:
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
at java.lang.ClassLoader.loadClass(
at java.lang.ClassLoader.loadClass(
at org.eclipse.equinox.launcher.Main.invokeFramework(
at org.eclipse.equinox.launcher.Main.basicRun(
at org.eclipse.equinox.launcher.Main.main(

I am using Windows 7, jdk1.8.0_60, maven 3.0.5 and installed openHAB2 with ESH.

Furthermore, I installed openHAB2 with ESH on another machine with ubuntu 14.04 and it is working fine. Only in the openHAB_Runtime.launch I had to insert javax.jmdns@default:default, because it was the only thing missing.

Well, this morning I installed the openHAB2 with ESH on a new ubuntu machine and it shows the same amount of errors:

Here I am using ubuntu 14.04 64Bit, oracle java 1.8.0_60, maven 3.0.5. I tried to clean all my projects and run Perform Setup Tasks..., but still the same errors. I still followed the instructions of this tutorial. Could someone please give me an advice what I should try next? Is there someone with the same problems as me?

It was a problem with java. I uninstalled my java version and installed java manually again and now it runs fine on my ubuntu setup from this morning. Keep wondering why it worked once on the other ubuntu pc.

1 Like

Having the same issue in Windows. I will try reinstalling Java to see if that fixes it. Thanks for posting this.

I uninstalled all java files I could find on my windows system and installed the jdk1.8.0_60 version again. Now after installing openHAB with ESH again it works fine aswell.

For everyone with the same issue, it’s important to insert the correct paths in the Eclipse Installer!

  • On the first side in the Advanced Mode... I entered at Java 1.7+ VM: the following path: C:\Program Files\Java\jdk1.8.0_60.
  • Secondly, watch out on the third side with the Variables to check the checkbox to Show all variables. Then for the JRE 1.7 Location: I set C:\Program Files\Java\jdk1.8.0_60\jre.

Followed your instructions exactly and it worked great! Thanks, Jan.