Setup of openhabian

Can anyone please help me with my problem?
Im trying to install a clean openhabian on my unit but i can’t get it to work.

  • Platform information:
    • Hardware: RPI 2 & RPI 3B+
    • OS: openhabian

Here is the bootlog

2018-03-13_22:53:37_UTC [openHABian] Starting the openHABian initial setup.
2018-03-13_22:53:37_UTC [openHABian] Storing configuration... OK
2018-03-13_22:53:37_UTC [openHABian] Changing default username and password... O
2018-03-13_22:53:38_UTC [openHABian] Setting up Ethernet connection... OK
2018-03-13_22:53:38_UTC [openHABian] Ensuring network connectivity... OK
2018-03-13_22:53:38_UTC [openHABian] Waiting for dpkg/apt to get ready... OK
2018-09-01_22:15:17_UTC [openHABian] Updating repositories and upgrading install
ed packages... FAILED
2018-09-01_22:15:33_UTC [openHABian] Initial setup exiting with an error!

First make sure that your internet connection is working. Are you using wifi or ethernet connection? Redownloading the image and reflashing your sd card is one thing you can try if everything else fails. I have seen many posts about openhabian install or upgrade problems so have you tried search already?

The unit is connected to Ethernet.
I can ssh in to the unit.
Tried install a clean raspian and that worked like a charm but the openhabian doesn’t work.
I have downloaded and flashed SD with two different computers already.
Yeah I have searched and tried alot of different things but can’t really get it to work.

Then you can try manually running upgrade process.

sudo apt-get update && apt-get upgrade

See this also: Openhabian - Raspberry Pi 3 - Installing git package... FAILED
Theres also discussion about apt failing.

I will try it. But how do I exit the log that is started when I ssh into the unit?

Press “ctrl+c” after logging in.

I have faced similar issue before… The problem was my internet package was exhausted. After I recharged it I got the connection. You must check for the Internet availability over LAN by using a PC/Mac using the same cable that you connected to the pi. You can login Via LAN even without Internet if your Raspberry Pi and PC/Mac is connected to the same router.

Thanks Miika!
Will try it tonight.

I found the solution after some more digging on github. :slightly_smiling_face:
It seems to be the start.elf file that is the problem.
I found this GitHub link.
It was reported as a bug and supposed to be fixed in this release but i still had to replace the file with a new from the latest rasbian release.

1 Like