Setup trouble: openHAB2, KNX, TUL (, knxd

My actual goal is to control my KNX stuff (lights, shutters) with openhab 2. But I’m already stuck with the basics or technical preconditions. I know that this is not a real openhab issue, but I guess I have a pretty common setup, so other users of openHAB(ian) might benefit from this post as well.

My setup:

  • Raspberry PI 3
  • TUL Stick flashed with “transparent TPUART” firmware plugged into RPI3 and connected to KNX bus (done by my electrician, so should be okay)
  • clean install of newest openHABian release
  • nothing else has been done (neither on software nor on hardware side)

My expectations:

  • install “knxd” (at best via openhabian-config)
  • after successful installation “knxtool vbusmonitor1 ip:localhost” on my pi should list some KNX packages when I turn on/off my lights, shutters, …

Real world:

  • I need to adjust openHABian’s KNX install script to successfully install knxd 0.10.18 or 0.11.18 instead of master which currently fails (already reported this here)
  • Even after successful installation of knxd the command “knxtool vbusmonitor1 ip:localhost” on my pi never brings any output


  • Are my expectations wrong?
  • Is there anything I misundestood?
  • Is the “transparent TPUART” firmware the correct one or do I have to use the “FT1.2 serial port BCU” firmware (IMHO not, but I also tried this without success)
  • “knxtool vbusmonitor1 ip:localhost” SHOULD list something when I switch lights, right?

Cheers. And sorry if this post is off-topic here. I’ll delete it in this case.

1 Like

Unfortunately, I don’t have experience with the knxd and the TUL Stick but I have a suggestion:

The KNX Binding (version 1.x) for openHAB 2 has an option to use a Serial port of FT1.2 KNX interface directly in the knx.cfg (never tried it since I use multicast to connect to my KNX/IP Router)

Have you thought about using the FT1.2 firmware for the TUL Stick and go directly with the KNX Binding (without having knxd in the middle) ?

Thank you for your reply.

I did not even know that accessing the TUL directly via FT1.2 is possible from openHAB. I’m completely new to all this and don’t even know the difference between the “FT1.2” and “transparent TPUART” firmware.

From what I’ve read in other forums, ETS5 and ETS4 with 64 Bit (the one I have), does not support FT1.2 anymore. And since I want to use the TUL also to program/update my KNX devices, FT1.2 seems to be not the option I was looking for. :frowning:

Any other suggestions what might go wrong in my case/thinking?

Oh my god … it’s working as expected now.

What I did:

  • new clean install of openHABian
  • build the latest source code of knxd (0.12.x) exactly as detailed here
  • followed the stuff in section “Adding a TPUART USB interface”
  • modified /etc/knxd.conf
  • reboot

Done. Now I can see the packages with knxtool. Perfect. Now I can move on …

So the problem was some combination of openHABians install script for KNX and knxd 0.10/0.11. Well, I don’t care anymore.

1 Like

same Problems here, with PI 2B
I just want to make a new Install with openHABian 2.0 and KNXd to connecto to BJ Powernet,
but the USB Port Detection does not work and also the knxtools are missing…
Sems the Install Script has Problems.

Only this files exist, no knxtool

[19:22:55] root@openHABianPi:/usr/local/bin# ls  openhabian-config  pthsem-config

The Last Messages from the Installer Script

checking whether __APPLE__ is declared... no
checking for gethostbyname_r... yes
EMI because of ft12
checking for LIBUSB... yes
EMI because of usb
checking for ev_run in -lev... no
configure: error: libev not found
make: *** No rule to make target 'clean'.  Stop.

Here the USB device

Jan 26 21:29:04 openHABianPi kernel: [    3.737192] usb 1-1.5: new full-speed USB device number 4 using dwc_otg
Jan 26 21:29:04 openHABianPi kernel: [    3.857222] usb 1-1.5: New USB device found, idVendor=145c, idProduct=1330
Jan 26 21:29:04 openHABianPi kernel: [    3.859061] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Jan 26 21:29:04 openHABianPi kernel: [    3.860873] usb 1-1.5: Product: KNX-USB Interface (Flush mounted)
Jan 26 21:29:04 openHABianPi kernel: [    3.862714] usb 1-1.5: Manufacturer: Busch-Jaeger Elektro GmbH
Jan 26 21:29:04 openHABianPi kernel: [    3.880048] hid-generic 0003:145C:1330.0001: hiddev0,hidraw0: USB HID v1.01 Device [Busch-Jaeger Elektro GmbH KNX-USB Interface (Flush mounted)] on usb-3f980000.usb-1.5/input0

Is there a new Install Script that will work with OpenHABian Image?


Here are the details:

Short answer: No, there is no new install script yet. I currently build the latest knxd myself according to the website of knxd. The author of the original install script did not respond so far.

If that is still the case, let’s replace the third party script by our own algorithm. Could you please provide all needed information, ideally a working set of commands?

Hi I am having issue installing the knxd component on openhabian-config file they say there are some problem contact github for that component.

I am new to this and I am also trying the same thing which you did… Automation of a room using Raspberry Pi 3 B+ model, KNXD, OpenHAB and TUL stick. I am done with the installation of KNXD on Raspberry Pi but I am unable to figure out how to install Transparent firmware on TUL stick. Should I connect it to my laptop and flash with the hex file?
And also my laptop isn’t detecting the TUL stick.

Thanks in advance

Hi All,
I found a way to flash the firmware. It is this

But my Raspberry doesnot detect the TUL.

When I use lsusb, I get the output as follows:
pi@raspberrypi:~ $ lsusb
Bus 001 Device 004: ID 03eb:204b Atmel Corp. LUFA USB to Serial Adapter Project
Bus 001 Device 005: ID 0424:7800 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

But with dfu-programmer, I get:

pi@raspberrypi:~ $ sudo dfu-programmer atmega32u4 flash TPUARTtransparent.hex
dfu-programmer: no device present.

Thanks in advance