Severe lag issues with SBCs (single board computers)

I’ve just tried openHAB2 on a Raspberry PI 2 as well as a Banana pi M3. Both demonstrate the same behavior: the java process raises at the top of the “top” process list and while it’s there… I can send/receive no commands from openHAB2 to my arduinos listening on a MQTT server.

The PI was setup with the image provided for it by openhab, the M3 was setup using its raspbian base image, then installed openHAB2 via package repo.

I’ve tried the same setup on a windows machine (leaving the MQTT server on the PI and/or M3) with vibrant success. As soon as I try starting the openHAB2 service on any of them… The severe lag begins. My network has no latency. Everything runs fine from a windows box. Involving the SBCs gets me in trouble.

Any ideas?

Latest Oracle Java or OpenJDK or an Oracle Java before 1.8.0_111?

very good question… 111 they are.

Are you by chance using persistence and charting? On another thread a user is experiencing OH running amok until it runs out of heap space when trying to view charts.

People routinely deploy to board computers so I’m not sure what is up here.

Hello Rich. No, I have a very minimal setup as I am a noob at this.

I have network bindigns, yahoo weather and astro for a few interesting eclipse data, transformations, 2 led strips controller from an arduino and MQTT. That is all there is to it.

I wonder though why there are 225+ items in my inbox with IP addresses out of my statically assigned range.

Is there anything I can check to help you help me find a cause to this?

Thank you so very much for helping.


The Items in the inbox are devices that responded to a ping at some point when the Network binding went into fdiscovery mode. I can’t answer why it is finding them or what they may be.

I know of no other reason why it won’t work. Other report successfully running on Pi 2s, though the 3 is better. I run it on an old laptop.