Shelly Binding

The pull request has been merged. How does that work now? Do we have to update something within openHAB? Or in Linux?

Somewhere there is a nightly build based on merged code, but I lost the link.
The other option is to wait on the next SNAPSHOT release.

I’ll update the DEV build based on merged code asap (as possible, maybe at the weekend), which includes latest changes.

fyi: I’m currently working on

  • support 3EM’s neutral current measurements
  • support for devices connected to a hub device (range extender mode)
    who could help testing? Who has a 3EM setup for ncurrent measurements?

I can help testing range extender mode.

/Mike

@tnemrap Please try this build:

First discover and initialize the device acting as a hub
once initialized you should the the secondary devices in the inbox

Hi i got the same issue with Blu Button1, if i run the script in the Shelly APP it works for a time(minutes-hours).

Did you try changing line 97 of the script? Be aware openHAB overwrites it every time it’s started up again.

1 Like

i have change it now :slight_smile: i will check if it works!
i have checked it, and it works.

Good hint. Worked fine for me aswell.

Adding the blumotion as blumotion the shelly only gets online shorty, when the button is pressed.
As bluebotton, manually added it works and stays online.

Renaming the script on the shelly that is used as gatway for the blu devices helps, that line 97 is not overwritten anymore.

fyi: Shelly has a surgery, attendees get a 15% voucher on survey completion
Even if you don’t intend to buy new stuff, please join the survey and mark openHAB als platform

Hello,
For me the script does not even run. I immediately get the error

MJS error: [BLE] is not defined

Any ideas?

Go to the Shelly device via your browser, and start the debugging. Make sure you don’t close the browser. You’ll get more info.

Did you change line 97?

How do I start the debugging. I don’t see any “Diagnostics” button.

The button at the bottom of the left-hand menu normally.


This is what I see. Would be great if somebody could explain in more detail how to get to “Diagnostics”.

That’s different from how it looks for my Shelly Plus 1PM… Maybe somewhere in those menus?

you are on a beta, I would recommend to update to 1.1; there are a lot of fixes and improvements since the 0.x versions

Seems like the Shelly is not connecting to the internet. It is flawlessly available locally but will not connect to the cloud (or download the new firmware. No idea why that is. Is there a setting to enable internet access?

Of course :sweat_smile: I would try ‘Networks’… :wink:

Now I am confused. In networks I see this:


Of course the device is connected to WiFi. Imcan enable “Cloud” but it stays at “connecting”. The other topics don’t look to like a requirement for internet acess.

you don’t need to activate Shelly Cloud to upgrade the firmware. Maybe contact Shelly support