Shelly duo temp and brightness

I’m having some issues setting the color temp for a shelly duo GU10,

I’d like to ad 2 channels but the documentation is a bit wierd:
white Color settings: only valid in WHITE mode
temperature Number r/w color temperature (K): 0…100% or 3000…6500
brightness Dimmer Brightness: 0…100% or 0…100

if i do the brightness alone it works, if i do the temperature alone i get the 3000-6500 view with a non working slider.

but since one is a number and the other is a dimmer I’ve got no clue.
plus do i need a transformation to get the temperature to use the percentage in the gui but shows 3000-6500?

You have to change the default widget for the Color temperature and set the min/Max to 0/100 instead of 2700/6500

Seems to be a bug when generating equipment from the thing.

Ny pointers on how to do that?

And how can I ad the 2 channels to the 1 item

From the thing you say add equipment to model and add all channels.

Then on the thing, open the temperature, say „add metadata“ and chose default widget (all three types. Stand alone, row, cell) ans klick the Advanced checkbox.

Ah ok I create them with the item/ things file
I’ll have to look into using the GUI,
Or do you happen to know how to do it with text

strange, i’ve done as instructed,
the slider does indeed appear afterwards and is movable,
but unfortunately, it doesn’t function

Try to do it via GUI. It definitely worked for me, but I have since flashed my Duos with Tasmota.

thats what i did made the item and editit the temperature to 0-100

did you use number or dimmer for the temp?

1 Like

Was searching for this for a while, thank @jeroenvdd, your solution does work for me, thanks!

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.