Shortcuts defined with IOS 15 using OpenHAB don't work correct on AppleWatch

Hi there,

with IOS 14 / WatchOS 7 the shortcuts using OpenHAB-Items were working correctly on AppleWatch.
With IOS 15 there is a problem with a “data protection” issue.

When I run the shortcut on iphone, the iphone ask once if the “ShortCutName” may share Data with “OpenHAB”. if you say “Yes” it stores this in the shortcut-configuration. Later I can run the shortcut again and again and there is no question.

If I run the same shortcut on my AppleWatch the question is the same but instead of “OpenHAB” it is “(null)” and the watch can not save my answer. so the question comes again on every run…

My first idea was, that could be a bug in WatchOS 8, but with my AudiApp the same this works very well on AppleWatch and the question on the watch doesn’t contains “(null)”. Ony when dealing with the OpenHAB-App on the iPhone it occurs.

I have open a support case at Apple but they only suggest to reset the watch and reinstalling OpenHAB-App on the iPhone. I have forced them to forward the problem to developers…but I don’t have a feedback yet.

Can anybode reproduce this problem here?
Or have somebody an idea, how to fix it…?


I’m also getting these privacy approval messages on my iPhone running iOS 15, to allow the shortcuts app to share data with the OpenHAB app.
Another problem is, after allowing the shortcuts app to share data with the OpenHAB app, these approval questions are asked again after a period of time. For some reason the approval status is forgotten.
Also, sometimes running shortcuts with a Siri voice command fails and returns an error message, but when the same shortcut is run within the Shortcuts app by pressing the shortcut, the command will run properly.

1 Like

Hi @hmerk ,
do you know who one of the current developers is who could keep an eye on it?


@digitaldan Can you have a look please.

Well, i have not touched the code base in a long time, but i’ll give a look and see if i can figure something out this weekend.


some news in this case ?

ok. update from myself:

It seems to be an apple-bug - not an OpenHAB-specific problem.
Look here:
Allow to share data with (null) ??? - Apple Community

But Apple does not care the problem actually…it wasn’t fixed with WatchOS 8.01