Show Grafana chart without title bar

Hi,

I created two grafana charts on a dashboard which I want to show in my HABPanel dashboard.
In HABPanel I took a frame widget and entered the URL from the Grafana dashboard (using share function).
So far so good. The Grafana dashboard I can see inside my HABPanel widget:

My question now how can I remove the Grafana title bar (marked in red in the attached image)
I only want to show the chart without any other things from Grafana.

Is there any way to get this done? How please?

Thanks…

Add

&kiosk

to the end of your url

edit: you can also go into fullscreen by additionaly adding
&fullscreen

2 Likes

Thanks, that works now, but I have a further problem now,
There is a fading border around the chart. In Grafana there is no border so I guess it comes from HABPanel widget somehow:

HABPanel_Grafana_Chart2

In the widget settings I activated ‘borderless’ and transparent:

but as you can see there is this (ugly) border.
How can I get rid of this border to get most of the space of my mobile phone?

Thanks for any further help…

Did you try with &fullscreen&kiosk?

Hi Simon,

yes this is my url:

http://openhabianpi:3000/d/nNTL6oggk/home?orgId=1&from=now-24h&to=now&panelId=4&fullscreen&kiosk

I used the developer functions of Chrome to get information to where the border comes from:

As one can see it comes from Grafana dashboard-container CSS padding settings (not as previously thought from HABPanel).

My question now is there any URL parameter I can use to get rid of this padding?
Or can I overwrite these padding settings somehow?
(Of course I can change it in the Grafana CSS file, but on every update it will get overwritten - which is not what I want)

Thanks for further help…

Has there been a solution to this?