Sienna Powerline Binding

@Carstens
I have created this new thread for those who want to use the “Sienna Powerline System” and openhab2 for their house automation.
follow the informations on the link below.
https://github.com/s-simma/openhab2-siennaPL

@carstens
i have updated the documentation and there is a binding update available.

@Siegi Danke fuer das update, bin noch in den Anfaengen, versuche gerade openHAB auf einen BeagleBoneBlack zum Laufen zu bringen, danach dann das serielle Gateway (fuers USB scheint es keine ARM basierten Treiber zu geben, dann gehts hoffentlich zuegig weiter mit Deiner Info. Werde mich melden wenn es soweit ist.

@carstens english please!

@ Siegi
Hi, I started to play around with the powerline binding but have to admit that I’m new to openhab. I installed openhab2 on a beagle bone black with Debian Jessie, as package openhab2-offline VErsion 2.0.0 b4. I copied the powerline binding and used the paper UI to configure a serial gateway and some devices. They appear online but there is no visible activity when I press some buttons. According to the log, I see errors likepaper ui
Sienna SerialConnector/write(): Record size is not required size (This can only be a bug in the binding…grrr)

Do you work with a usb or serial gateway, on which OS? USB is apparently no option on arm as there seems to be no drivers around, only for Windows and Linux on Intel hardware?!

The other point where I’m surprised is that a rollershutter is displayed as 2 inputs, 2 outlet, 1 position and 1 angle in the paper ui or basic ui and the position and angle is not diplaying values.
Any ideas?

Thank you.

@carstens

  1. Please read the whole documentation first
    https://github.com/s-simma/openhab2-siennaPL

  2. I never used paper-ui. I can only help you if you start with creating config files by use of a text editor (e.g. notepad++) or the eclipse smarthome designer.
    https://github.com/eclipse/smarthome/blob/master/docs/documentation/community/downloads.md#designer-builds

  3. Which Sienna modules do you want to implement ? Do you already have the Neuron-Id of your devices? Are you sure you have the sienna gateway called “PL-20-ST01-H01” This is not the same as the USB programming adapter !!!

  4. The Sienna Gateway uses a serial interface (connected to usb). You need to know the name of the serial device where your gateway is connected to (e.g. “/dev/ttyUSB0”) This is independent of openhab !!!. Connect your gateway and use linux board commands (google will help you) to determine the serial device name.
    What shows: ls -l /dev/ttyU*
    Try this with connected and disconnected gateway (check write permission)

  5. Did you download the latest binding ?

  6. Which files do you have in your “addon” folder ?

  7. How does your “things-config file” looks like ?

@carstens

Record size is not required size means: Length of Neuron-ID is not 12 character or missing Group/Element ID.
it should be like neuronId=“0503E1D2E200”

To Show the debug infos of the binding use following command in the karaf console:
log:set DEBUG org.openhab.binding.siennapl
(it should hopefully show you what is missing)

Rollershutter:
The inputs show the state of the local buttons “UP, DOWN”.

It seems, that you are not far away to have the system running.

Hi Sigi,
thank you for the info. Didn’t have much time to spend but got a bit of progress. Connectivity/gateway problem was simply the access right to the serial-usb device, i.e. I have the serial device connected through a usb2serial adapter hooked up on my beaglebone black. Adding the user openhab to the usergroup “dialout” in this case solved the problem. Main problem after that was getting openhab running as a service, i.e. manual startup was OK, but running as a service at startup failed with errors. I found people with similar issue, but no solution. Finally ran a update/upgrade of the packages last weekend, but that apparently killed the internal flash, the root was readonly, the system didn’t get up again, so had to pull out the uSD again and tried to reflash, which was not successfull. Apparently I don’t get a devicename for the internal flash anymore. So lost one weekend on that. Re-installed now openhab 2 stable on a debian 8.7 on the beaglebone blach uSD, and surprise: not it starts as a service. So will install the sienna packages again, and start looking into designing the interface, I understand that habpanel is best. And will look into connectivity issues betrween the gateway and the modules, looks I don’t reach all at the other end of the house, the usb dongle seems to be a bit better. So will probably relocate the beaglebone and gateway searching for a place where I can connect up the beaglebone to network and have best connectivity through the gateway to the modules. I put some ferite cores on the powercable of a notebook which solved the issue in one room. Thinking now whether I put a ferrite directly into the box on the outputlines of the modules, this should fit better than the filetrs you can buy extra.

Hi,
I have updated the Sienna Powerline bindung to v0.7.

  • Minor changes
  • Documentation
  • some HAPpanel deshboard examples with 3-state sensor/actors (thank’s to @ysc)
1 Like

@s.simma your dashboards are pretty good looking! :thumbsup:
You didn’t seem to provide the code of your custom widgets though (or I didn’t look good enough…).

It would be very cool if you could share the screenshots and the .json files for the widgets in a new topic with screenshots in the HABPanel Examples category, with a a link back to here or your repository - when you find the time of course :wink:

https://community.openhab.org/c/tutorials-examples/habpanel-examples

Thanks!

Hi @s.simma ,
I have followed you’re instructions to bind the Sienna with OH2. but for some reason the PL-20 doesnt recieve any Signals. Is there any Other port that can be used? or is there a way to find where it is pugged in?
thank you

Hi,
You can use any port that can be seen in the operating system. And in case of linux you need the access rights to write to this port.
Is your OH2 running on linux or windows ?

@MArk97Coder
If you use linux, check if USB-Serial modul is loaded.

“lsusb” should include a line with
Bus 002 Device 002: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC

and
"dmesg" should include a line with
usbserial: USB Serial support registered for FTDI USB Serial Device

hi @s.simma
thank you for you’re Response.
When i do ‘lsusb’ i get :
Bus 001 Device 004: ID 0403:8348 Future Technology Devices International, Ltd
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

and then i did dmesg i didn’t recive the line u were talking about (usbserial: USB Serial support registered for FTDI USB Serial Device) what could i do?
Kind Regards

@MArk97Coder
That’s what i thought.

In your kernel the usb-serial modul is not included. What type of hardware/operating system do you use ?
So you have to load this modul on startup of your system. If you don’t give any information about your hardware / operating system it is very difficult to help you:wink:

A tutorial for e.g. ubuntu how to do is:
https://blog.mypapit.net/2008/05/how-to-use-usb-serial-port-converter-in-ubuntu.html

Hi
i am useing a Rasperry PI 3
soor that i forgot it :sweat_smile:

I’m sure there are many specialists in this forum who know how to do this on the PI 3.
I hope one of them can answer this question.

Ok thank you. i have tried ure link but it didnt help me :frowning: hope someone knows how to fix this issue

Hi Siegi,

thanks for creating and sharing the Sienna powerline binding.
May I ask why you changed the mode of operation concerning the shutter item within the last versions? I was using the BasicUI GUI and it was possible to get information and send the position of the shutter as well as the command to only one item. Now it is neccessary to create a couple of them.

Can you maybe provide a more detailled changelog or the reason why this had to be changed? Is there a chance to get the source files for the bindings in order to restore the old functionality ?

Thanks in advance

marek