Simple (?) password problem

  • Platform information:
    • Hardware: Raspberry Pi 4
    • OS: Raspbian Buster
    • Java Runtime Environment: Java 8
    • openHAB version: per Openhabian 1.5
  • Issue of the topic: I’m new to Linux and have done very little command line computing for many years. I completed setup by ethernet using openhabian v1.5, and made a written note of personal passwords whenever used, but when I tried to log back on using ssh by ethernet from my Windows 10 computer, my password and all imaginable variants were rejected. So I formatted the SD card (though only the boot partition was visible on my PC), re-installed openhabian, emptied the knownhosts file and tried again to log on, only to find my password still required but not accepted. The actual password request is: Mike@openhub’s password: . I had gone through all the steps for configuring Samba etc, which was possibly unwise at this stage. Where is this password stored, and how can I reset it? Or is there another workaround? Any help much appreciated.

WHat connection does not work, ssh or samba?

Need more info to help.

Did you use the openHABian image or did you install Raspbian first openHABian manually next? If the latter, what does “reinstall” mean ?
What account do you talk about ? There is no personal account on default openHABian installs, you are supposed to use “openhabian”. If you flash the card, any account you might have added before will be gone so it’s no surprise it doesn’t work any longer - youneed to create it again.
As user openhabian, you can sudo cmd pretty much anything as root.
As you talk about changing passwords I assume that access is still working.

Thanks for quick responses, Danny and Markus, and apologies for my lack of precision.
Having found no way around the password problem, I had formatted and re-flashed the SD card with the Openhabian image; as before, I did not install Raspbian from any other source. I did not attempt to edit the openhabian.conf file as I do not know what parameters I should set. The “Quick Format” took no more than 5 seconds, so I did wonder whether only the root partition was formatted, but as the remainder of the card is not visible in Windows I can’t check this.
After inserting the re-flashed SD card, I had to take it back to my PC to clear the contents of the knownhosts file because its ID had changed. I was then able to SSH to the IP but not to “openhabian”; “openhab” was also recognised, which surprised me as I had not gone through any of the configuration process since re-flashing. “openhabian” was not recognised as my password. In short, re-flashing seems not to have eliminated any of my original configuration data, which I probably messed up by taking steps in openhabian-config that were unnecessary and perhaps wrong. As for being addressed as Mike@openhab in the password request, is this something I inadvertently set up in my original configuration efforts?
So, Markus, I would like to get back to being user openhabian, but I don’t know how to do it. Does this boil down to finding a way to remove all data from my SD card? All my hardware is currently running Windows. If I was to flash a different SD card with openhabian, would I later be able to erase my old SD card using Raspbian on my Rpi that is set up only for openhab?
Danny - I’ve only used SSH straight from Windows PowerShell - I have no idea how to use Samba.

To be frank I don’t understand what you’re doing there.
Start over: flash again, let it boot and install, then there will only be the openhabian user.

Markus, I had done exactly what you said, but I did it again and, of course, got the same result. However, I have solved the problem after some hours of web searching. As a Linux newbie and command line novice, I had been using ssh {IPaddress}, which caused the system to ask for the password for {myusename@IPaddress}. Once I discovered that I could use ssh openhabian@{IPaddress} the problem was solved. No doubt all this is obvious to a Linux user, but the Openhabian instructions gloss over the need to use ssh in this way, and the embedded information that comes up after entering ssh on its own is pretty opaque to a novice. Anyway, many thanks for trying to help.