Since today timer are not triggered anymore OH 2.5.8

  • Platform information:
    • Hardware: Intel CPU
    • OS: Win10
    • Java Runtime Environment: zulu java
    • openHAB version: 2.5.8

I run into a strange problem today. Since today I ca nset tiems with no error, but the are never trigger time end action.

I changed nothing in my config since months. This starts happen today.

Is there a bundle which I should restart to bring timer back to work?

It looks like something in OH was no longer working. I restarted OH and now it works again.

This leads me to the question how to check if a timer is really scheduled?

        if(tTestTimer !== null)
        tTestTimer = createTimer(now.plusSeconds(10),
        [ |
            logInfo("Logger", "tTestTimer beendet")
			tTestTimer = null            
        ] )  

At which position I can add code to check if the timer is really working?

        tTestTimer = createTimer(now.plusSeconds(10),
        [   logInfo("Logger", "tTestTimer started") 
            logInfo("Logger", "tTestTimer ended")
			tTestTimer = null            
        ] ) 

bring syntax error. It looks like there is no way to run code right after timer is started and before it is ended?