Sitemap no longer available when not connected to home network (via OH-Cloud)


i made some changes to my sitemap and something broke it …
I can use it fine when connected to my wifi but when i disable WiFi and try it over the myopenhab cloud it responds:

OH delivers an empty sitemap list

I can’t wrap my head around that.
I tried creating a new sitemap and it’s the same …

myopenhab tells me that it’s online …
if i click on home however
Your openHAB is online. Click here to access your openHAB’s dashboard
it does only show a white page.

thank you for helping!

Sorry, for some reason we cannot see your configuration across the Internet.

How to ask a good question / Help Us Help You - Tutorials & Examples - openHAB Community

1 Like


sorry, you are rigt …
i am on debian vm now and running openhabian with the latest snapshot.
i tried accessing via the iPhone app.

on my phone i did not make any changes - neither did i edit the .cfg-file.

url for remote access is set to
and i put my myopenhab

username and password in the fields.
i tried it with “always send login data” on and off - no success.

the config file for myopenhab is empty because everything is optional.

i did only edit the sitemap file …
I made a new one with just one item and i can see it locally but i have the same problem when disabling wifi and trying over lte.

Jonas88, we still don’t know your openHAB version!

We now have threads with a similar problem regarding the Android and iOS app, so it is not an app problem. But it looks like it is bound to version 3.1.0 M4.
I will open a github issue later this day.


I couldnt find the other thread because i did not know how the error correctly translates …
I wrote above that i am using the latest snapshot (build 2378) so it really seems to be the same issue that your are facing.
Thanks for your support!



Any idea how I can debug this?
I looked into the code of but even if I compile this with extra debugging, how can I install this in my openhab environment? That is not clear to me.

Has there been any resolution to this? I see the openHAB returns an empty sitemap list on Android and iOS app · Issue #351 · openhab/openhab-cloud · GitHub has none and still same issue for 3.3.0.M6 and 3.2.0 (tried both). Works just fine with 2.5 :frowning: Anyone?

I had the issue as well. But recently it just started working again.
Nothing changed on my side.
Only think still not eirking is chartsxand maps. They just dont display.

Still broken here … “Empty Sitemap list”.

1 Like

same here …
really annoying

Response could not be serialized input data was nil or zero lenght …

Surely someone with OH3 uses this successfully or is the OH-Cloud thing not as used as one would suspect? I use it a lot for my OH2 install but clearly can’t migrate off yet.

I’m tempted to try and do a nginx reverse proxy and see if it fixes… anyone tried that? Seriously a bummer that the OH-Cloud bit isn’t viable for OH3. Seems like there is no fix for this. I tried on the latest IOS version (2 day olds) and the current beta and reguarl… definitely see it coming through in the logs just somehow isn’t passing the sitemaps or ui properly back. Very frustrating. Honestly expected tons of people to use Openhab cloud…

I’m on OH3 and have never had this problem with the myopenHAB cloud. I would assume that most people don’t have this issue.

Perhaps it’s related to a specific type of element? I have one sitemap that uses:

But I don’t use:

I don’t think that will help if the issue is with the cloud connection. You could try setting up a new myopenHAB account to see if that fixes the problem.

Thanks for the reply Russ. That gives me some hope. I even created a new openhab account and spun a fresh vm and fresh openhab install and only added in 2 shelly switches and it still won’t load the sitemaps on. Works locally but over the cloud it’s a no go. Wonder if there is something else that is wonky. Anything you change on yours and what version are you running?

I don’t get the /rest/sitemaps over OH cloud but /rest/ and /rest/items show fine. It’s just something about getting /rest/sitemaps but if I try it locally, it works fine.

There’s nothing special about my installation. I’m running openHABian on an RPi4, but none of that should make a difference. myopenHAB just fetches BasicUI and passes it on.

Try accessing your sitemap directly in the browser through myopenhab:

I’m curious if it’ll work or not.

That does but then clicking it just gives me a blank page


Is your sitemap a text file, or did you build it in MainUI?

Also, what happens if you go here:

I get the following:


So I built it via the UI. Works locally with the app fine. But if I try it returns nada. Shows it locally though so maybe something around the ui components page or something with OH cloud? My OH2 is textual and it works fine. Here’s an image where I get nothing over OH cloud but locally it works. Same with over 8080