Sitemap shows 2 entries

(Paulo Wollny) #1

Hya,

sorry if it was already answered, but could not find it.

I’m an absolute new openhab user, and following the procedures , i created the first sitemap, creating /etc/openhab2/sitemaps/default.sitemap.

When in hbadmin panel, under sitemap, i find two sitemaps, the one i created and another home, called home, with the link showing http://localhost:8080/habmin/index.html#/sitemap/view/_default/_default which shows me the right panel with title Home
When trying the created one, http://localhost:8080/habmin/index.html#/sitemap/view/default/default, right panel shows no title.

Questions:

  • how to discard the _default/_default?
  • why does the created one (PJW Home) shows no title?

Thx in advance.

BR

0 Likes

(Jürgen Baginski) #2

Welcome to the openHAB Forum.

Please show the contents of your sitemap file. Without that we can only guess.
The _default sitemap is created automatically and can’t be deleted.

0 Likes

(Paulo Wollny) #3

Thx for answering.

the content

sitemap pjw_home label="PJW Home" {
    Frame label="First Floor" icon="firstfloor" {
        Group item=FF_LivingDining
        Group item=FF_Toilet
        Group item=FF_Kitchen
        Group item=FF_FrontYard
        Group item=FF_Outside
        Group item=FF_LaundryRoom
    }

    Frame label="Second Floor" icon="attic" {
        Group item=F2_MasterBedroom
        Group item=F2_Bedroom1
        Group item=F2_Bedroom2
        Group item=F2_Bedroom3
    }

}

i also tried to continue with homebuilder, but it starts from scracht.

0 Likes

(Jürgen Baginski) #4

This sitemap file NEEDS to be called pjw_home.sitemap.

0 Likes

(Paulo Wollny) #5

Thx. worked.

By homebuilder, is it possible to continue the definitions of this sitemap?

TIA

0 Likes

(Jürgen Baginski) #6

Sorry, never worked with Home Builder, I would have to read the documentation as well.

0 Likes

(Paulo Wollny) #7

thx, i guess i will have to start all over again :sweat_smile:

for the initial install, i have an esp8266 device, recognized by mqtt server, but trying to find it, did not work.
I installed the mqtt bindings, but openhab seams not to find it.

1557345105: New connection from 192.168.1.5 on port 1883.
1557345105: New client connected from 192.168.1.5 as ESPClient_EC:FA:BC:23:87:DC (c1, k10, u'').
1557345163: Client ESPClient_EC:FA:BC:23:87:DC disconnected.
1557345171: New connection from 192.168.1.5 on port 1883.
1557345171: New client connected from 192.168.1.5 as ESPClient_EC:FA:BC:23:87:DC (c1, k10, u'').
1557345303: New connection from 192.168.1.6 on port 1883.
1557345303: New client connected from 192.168.1.6 as paho10800054946750 (c1, k60).
1557345352: Saving in-memory database to /var/lib/mosquitto/mosquitto.db.

what could be wrong? sorry it it seams too basic, but as told, an absolute beginner on openhab and some of the docs are not so easy to understand.

TIA

0 Likes

(Rossko57) #8

openHAB is not an MQTT broker. If you have mosquitto running, you need to point your openHAB MQTT binding at mosquitto.

0 Likes

(Paulo Wollny) #9

Yes, i have it.

MQTT Binding binding-mqtt - 2.4.0 UNINSTALL

Configuration > Bindings > MQTT Thing Binding
MQTT Thing Binding
Supported Things
Generic MQTT Thing
HomeAssistant MQTT Component
Homie MQTT device
MQTT Broker
SystemMQTT Broker

Configuration > Things > Edit > MQTT Broker

Name MQTT Broker
Broker Histname/IP
192.168.1.6
Client ID
paho10800054946750 (as log shows 1557345303: New client connected from 192.168.1.6 as paho10800054946750 (c1, k60))

Have it all… but the thing is not being discovered

TIA

0 Likes

(Jürgen Baginski) #10

I think(!) that the automatic discovery in version 2.4 has isses, the author always suggest to go for the 2.5m1 Milestone version.

0 Likes

(Paulo Wollny) #11

Thx. Shall i delete current and install 2.5m1?

0 Likes

(Jürgen Baginski) #12

An update should also be possible, depends on your actual Setup.

0 Likes

(Paulo Wollny) #13

Thx! updated: openHAB 2.5.0.M1 Milestone Build

And still not discovering my esp device.

i go to inbox, +, MQTT Binding, but nothing is discovered.

Under services, i have:

MQTT Embedded Broker

org.eclipse.smarthome.mqttembeddedbroker

MQTT system broker connection

org.eclipse.smarthome.mqttbroker

0 Likes

(Jürgen Baginski) #14

For mqtt to work, you need a mqtt broker. That could be the embedded one or an external one like mosquitto.

0 Likes

(Paulo Wollny) #15

yes, i have the mqtt broker (mosquitto) already installed, and it talks to my thing - 1557423113: Saving in-memory database to /var/lib/mosquitto/mosquitto.db.
1557424914: Saving in-memory database to /var/lib/mosquitto/mosquitto.db.
1557425022: Client ESPClient_EC:FA:BC:23:87:DC disconnected.
1557425029: New connection from 192.168.1.5 on port 1883.

0 Likes

(Jürgen Baginski) #16

If the mqtt binding is installed, the next step would be to create a mqtt broker thing which establishes the connection between mosquitto and openhab.
After that either the autodicovery should work or you could create the Generic mqtt things.

I used the later only, so this is how far I could guide you.

0 Likes

(Paulo Wollny) #17

Also have it created as thing:

Configuration > Things > MQTT Broker

delete close edit

MQTT Broker

MQTT Broker

A connection to a MQTT broker

Status: ONLINE

0 Likes

(Jürgen Baginski) #18

Then you are set for the next step as written above

0 Likes

(Nick Devine) #19

I am just learning MQTT with OH2 at the moment and i do recall reading in the documentation for this binding [HERE] that auto discovery only works for MQTT Homie and HomeAssistant bindings.
I am using a generic MQTT thing and i have to set it up manually.

0 Likes

(Jürgen Baginski) #20

Good point, I was probably in false impression that Paulo used one of those.

0 Likes