Slow ethernet openhabian 1.4

Hi!

I have a problem after installing the new openhabian 1.4 with openhab 2.2. Both ethernet and wifi is very slow. Inside my network everything works fine but as soon as I want outside to the internet i get’s slow. Any ideas how i can figure out whats the problem?

[12:56:44] openhabian@openHABianPi:~$ time curl google.se
<HTML><HEAD><meta http-equiv="content-type" content="text/html;charset=utf-8">
<TITLE>301 Moved</TITLE></HEAD><BODY>
<H1>301 Moved</H1>
The document has moved
<A HREF="http://www.google.se/">here</A>.
</BODY></HTML>

real	0m5.690s
user	0m0.050s
sys	0m0.000s
###############################################################################
################# openHABianPi ################################################
###############################################################################
##             Ip = 192.168.0.8
##        Release = Raspbian GNU/Linux 9 (stretch)
##         Kernel = Linux 4.9.59-v7+
##       Platform = Raspberry Pi 3 Model B Rev 1.2
##         Uptime = 0 day(s). 0:0:55
##      CPU Usage = 58.44 % avg over 4 cpu(s)  (4 core(s) x 1 socket(s))
##       CPU Load = 1m: 2.44, 5m: 0.70, 15m: 0.24
##         Memory = Free: 0.46GB (49%), Used: 0.48GB (51%), Total: 0.95GB
##           Swap = Free: 0.09GB (100%), Used: 0.00GB (0%), Total: 0.09GB
##           Root = Free: 11.32GB (83%), Used: 2.19GB (17%), Total: 14.13GB
##        Updates = 2 apt updates available.
##       Sessions = 1 sessions
##      Processes = 146 running processes of 32768 maximum processes
###############################################################################

              Welcome to            __  _____    ____  _
            ____  ____  ___  ____  / / / /   |  / __ )(_)___ _____
           / __ \/ __ \/ _ \/ __ \/ /_/ / /| | / __  / / __ `/ __ \
          / /_/ / /_/ /  __/ / / / __  / ___ |/ /_/ / / /_/ / / / /
          \____/ .___/\___/_/ /_/_/ /_/_/  |_/_____/_/\__,_/_/ /_/
              /_/
                  openHAB 2.2.0-1 (Release Build)

My best guess is that there is a problem with the DNS settings (especially if you have configured static IP).

Check you /etc/resolv.conf file for entries.

Hm here my resolve.conf. Can’t see anything is wrong there

# Generated by resolvconf
domain home
nameserver 192.168.0.1
nameserver 8.8.8.8
nameserver 83.255.255.1
nameserver 83.255.255.2

Even a nslookup takes more than a second

time nslookup 8.8.8.8
Server:		8.8.8.8
Address:	8.8.8.8#53

Non-authoritative answer:
8.8.8.8.in-addr.arpa	name = google-public-dns-a.google.com.

Authoritative answers can be found from:


real	0m1.109s
user	0m0.070s
sys	0m0.010s

Hey! I figured out what the problem was! I had to remove the nameserver 192.168.0.1 that was stated in my /etc/dhcpcd.conf. After a reboot everything was find again!

Thanks for the tip!

1 Like