SmartThings and BobRak

Hi all

I’m a new user with the latest stable (installed yesterday) OpenHabian install. I set this up specifically to set up my SmartThings devices and I’m falling at a significant hurdle.

I’ve downloaded BobRak’s SmartThings binding into the addons folder and restarted OpenHAB, however I can’t find the binding or choose to add one from the list.

The install instructions don’t mention how the binding gets created, it just seems to assume it will be there.

Hope this isn’t too much of a noob question, I thought I was doing ok up until this point


The system automatically installs ( or tries to install) any binding in that location. You should see entries in the logs from when it was installed.

Really appreciate the response!

I’ve checked the logs and there’s absolutely nothing there about SmartThings.

==> /var/log/openhab2/events.log <==

2020-01-04 13:44:17.320 [thome.event.ExtensionEvent] - Extension ‘package-standard’ has been installed.
2020-01-04 13:44:37.013 [thome.event.ExtensionEvent] - Extension ‘ui-homebuilder’ has been installed.
2020-01-04 13:44:37.014 [thome.event.ExtensionEvent] - Extension ‘ui-basic’ has been installed.
2020-01-04 13:44:37.017 [thome.event.ExtensionEvent] - Extension ‘ui-habpanel’ has been installed.
2020-01-04 13:44:37.019 [thome.event.ExtensionEvent] - Extension ‘ui-paper’ has been installed.
2020-01-04 13:44:41.234 [thome.event.ExtensionEvent] - Extension ‘ui-dashboard’ has been uninstalled.
==> /var/log/openhab2/openhab.log <==
2020-01-05 13:42:50.410 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Time zone set to ‘Europe/London’.
2020-01-05 13:42:50.477 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Location set to ‘’.
2020-01-05 13:42:50.485 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Locale set to ‘en_GB’.
2020-01-05 13:43:05.067 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007
2020-01-05 13:43:07.235 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at
2020-01-05 13:43:07.242 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at
2020-01-05 14:12:38.576 [INFO ] [ebuilder.internal.HomeBuilderServlet] - Started Home Builder at /homebuilder
2020-01-05 14:12:38.862 [INFO ] [openhab.ui.paper.internal.PaperUIApp] - Started Paper UI at /paperui
2020-01-05 14:12:39.163 [INFO ] [panel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel

I downloaded the jar directly into /use/share/openhab2/addons, as I understand this to be the correct folder as this is OpenHabian and not a manual install

I’ve restarted the Pi immediately before copying these logs, so any entries from 14:12 relate to that restart

It’s like the jar isn’t even there

Putting the jar in that folder is a manual install of the addon. I have not tried manual install on 2.5 Stable but it worked on some of the Milestones I tested/

I’ve managed to get this working now, thanks

After finding this post - How to manually install JAR bindings?

I opened the samba share from my windows machine. The jar was already there, but I deleted it and re-added. As I was live monitoring the logs as I did this, I immediately saw the log respond and confirm Smartthings had started!

2020-01-05 15:02:26.336 [INFO ] [rtthings.internal.SmartthingsServlet] - Started Smartthings servlet at /smartthings

Thanks for taking the time to help Bruce :slight_smile:

1 Like

That is a typo (use) correct?

Check that openhab has permissions to the file or use the openhabian-config tool and run fix permissions then restart OH.

I hope so :wink: