Smartthings Zigbee outlet item in OH flips off as soon as I turn the outlet on

Tags: #<Tag:0x00007f43385fa0c8>

I recently upgraded from 2.4.0 M6 to the release version and I’m now having issues with my smartthings outlets. I’m able to to turn them on/off with the dimmer channel but for some reason when I turn it on the item in openhab flips to off… but the outlet stays on. I have to turn it back on in OH in order to turn the outlet off.

Here is what I’m seeing in the logs when I turn the outlet on:

08:49:43.137 [INFO ] [smarthome.event.ItemCommandEvent     ] - Item 'SamjinOutlet_Switch' received command ON
08:49:43.144 [DEBUG] [ing.zigbee.handler.ZigBeeThingHandler] - 286D9700010286C8: Command for channel zigbee:device:c8208aa5:286d9700010286c8:286D9700010286C8_1_dimmer --> ON [OnOffType]
08:49:43.183 [INFO ] [arthome.event.ItemStatePredictedEvent] - SamjinOutlet_Switch predicted to become ON
08:49:43.205 [INFO ] [smarthome.event.ItemStateChangedEvent] - SamjinOutlet_Switch changed from OFF to ON
08:49:43.516 [DEBUG] [.converter.ZigBeeConverterSwitchLevel] - 286D9700010286C8: ZigBee attribute reports ZclAttribute [cluster=ON_OFF, id=0, name=OnOff, dataType=BOOLEAN, lastValue=true, lastReportTime=Sat Dec 22 08:49:43 CST 2018]
08:49:43.524 [DEBUG] [.converter.ZigBeeBaseChannelConverter] - 286D9700010286C8: Channel zigbee:device:c8208aa5:286d9700010286c8:286D9700010286C8_1_dimmer updated to 0
08:49:43.533 [DEBUG] [ing.zigbee.handler.ZigBeeThingHandler] - 286D9700010286C8: Updating ZigBee channel state zigbee:device:c8208aa5:286d9700010286c8:286D9700010286C8_1_dimmer to 0
08:49:43.549 [INFO ] [smarthome.event.ItemStateChangedEvent] - SamjinOutlet_Switch changed from ON to OFF

Curious if anyone is having similar issues of if someone smarter than me might have insight into what I’m doing wrong.

This sounds related to the autoupdate update. I’ve seen similar behavior, but when Zigbee devices completely fall off the network and are unresponsive. I do have an ST outlet, and it is working fine, so this shouldn’t be device specific. I’ve also seen this with some dummy switches. This is likely an issue with ESH, or a feature that would need to be incorporated into the bindings.

Do you always have this behavior with this device, or does it clear up after a binding or OH restart?

Thanks for the response Scott! The problem persists through an OH restart. The outlets belong to a buddy who is transitioning away from his Smarthings hub to OH. I brought one of them home to troubleshoot on my system and I’m having the same issue. Both of our systems are on 2.4.0 release. They worked perfectly on his system prior to upgrading from 2.4.0 M6.

I just restarted OH to confirm. Also, I initially thought that if I turned the item on again it would stay on but that’s not the case. It looks like every time it polls it flips the item off. The outlet itself stays on.

10:15:56.450 [INFO ] [smarthome.event.ItemCommandEvent     ] - Item 'SamjinOutlet_Switch' received command ON
10:15:56.481 [INFO ] [arthome.event.ItemStatePredictedEvent] - SamjinOutlet_Switch predicted to become ON
10:15:56.484 [DEBUG] [ing.zigbee.handler.ZigBeeThingHandler] - 286D9700010286C8: Command for channel zigbee:device:c8208aa5:286d9700010286c8:286D9700010286C8_1_dimmer --> ON [OnOffType]
10:15:56.507 [INFO ] [smarthome.event.ItemStateChangedEvent] - SamjinOutlet_Switch changed from OFF to ON
10:16:12.349 [DEBUG] [ing.zigbee.handler.ZigBeeThingHandler] - 000B57FFFE8DD86D: Polling...
10:16:12.356 [DEBUG] [ing.zigbee.handler.ZigBeeThingHandler] - 000B57FFFE8DD86D: Polling zigbee:device:c8208aa5:000b57fffe8dd86d:000B57FFFE8DD86D_1_dimmer
10:16:39.585 [DEBUG] [ing.zigbee.handler.ZigBeeThingHandler] - 286D9700010286C8: Polling...
10:16:39.593 [DEBUG] [ing.zigbee.handler.ZigBeeThingHandler] - 286D9700010286C8: Polling zigbee:device:c8208aa5:286d9700010286c8:286D9700010286C8_1_voltage
10:16:39.799 [DEBUG] [erter.ZigBeeConverterMeasurementPower] - 286D9700010286C8: ZigBee attribute reports ZclAttribute [cluster=ELECTRICAL_MEASUREMENT, id=1285, name=RMSVoltage, dataType=UNSIGNED_16_BIT_INTEGER, lastValue=1199, lastReportTime=Sat Dec 22 10:16:39 CST 2018]
10:16:39.802 [DEBUG] [.ZigBeeConverterMeasurementRmsCurrent] - 286D9700010286C8: ZigBee attribute reports ZclAttribute [cluster=ELECTRICAL_MEASUREMENT, id=1285, name=RMSVoltage, dataType=UNSIGNED_16_BIT_INTEGER, lastValue=1199, lastReportTime=Sat Dec 22 10:16:39 CST 2018]
10:16:39.799 [DEBUG] [.ZigBeeConverterMeasurementRmsVoltage] - 286D9700010286C8: ZigBee attribute reports ZclAttribute [cluster=ELECTRICAL_MEASUREMENT, id=1285, name=RMSVoltage, dataType=UNSIGNED_16_BIT_INTEGER, lastValue=1199, lastReportTime=Sat Dec 22 10:16:39 CST 2018]
10:16:39.799 [DEBUG] [ing.zigbee.handler.ZigBeeThingHandler] - 286D9700010286C8: Polling zigbee:device:c8208aa5:286d9700010286c8:286D9700010286C8_1_dimmer
10:16:39.823 [DEBUG] [.converter.ZigBeeBaseChannelConverter] - 286D9700010286C8: Channel zigbee:device:c8208aa5:286d9700010286c8:286D9700010286C8_1_voltage updated to 119
10:16:39.833 [DEBUG] [ing.zigbee.handler.ZigBeeThingHandler] - 286D9700010286C8: Updating ZigBee channel state zigbee:device:c8208aa5:286d9700010286c8:286D9700010286C8_1_voltage to 119
10:16:40.030 [DEBUG] [.converter.ZigBeeConverterSwitchLevel] - 286D9700010286C8: ZigBee attribute reports ZclAttribute [cluster=ON_OFF, id=0, name=OnOff, dataType=BOOLEAN, lastValue=true, lastReportTime=Sat Dec 22 10:16:40 CST 2018]
10:16:40.036 [DEBUG] [.converter.ZigBeeBaseChannelConverter] - 286D9700010286C8: Channel zigbee:device:c8208aa5:286d9700010286c8:286D9700010286C8_1_dimmer updated to 0
10:16:40.040 [DEBUG] [ing.zigbee.handler.ZigBeeThingHandler] - 286D9700010286C8: Updating ZigBee channel state zigbee:device:c8208aa5:286d9700010286c8:286D9700010286C8_1_dimmer to 0
10:16:40.055 [INFO ] [smarthome.event.ItemStateChangedEvent] - SamjinOutlet_Switch changed from ON to OFF
10:16:40.218 [DEBUG] [.converter.ZigBeeConverterSwitchLevel] - 286D9700010286C8: ZigBee attribute reports ZclAttribute [cluster=LEVEL_CONTROL, id=0, name=CurrentLevel, dataType=UNSIGNED_8_BIT_INTEGER, lastValue=0, lastReportTime=Sat Dec 22 10:16:40 CST 2018]
10:16:40.222 [DEBUG] [.converter.ZigBeeBaseChannelConverter] - 286D9700010286C8: Channel zigbee:device:c8208aa5:286d9700010286c8:286D9700010286C8_1_dimmer updated to 0
10:16:40.226 [DEBUG] [ing.zigbee.handler.ZigBeeThingHandler] - 286D9700010286C8: Updating ZigBee channel state zigbee:device:c8208aa5:286d9700010286c8:286D9700010286C8_1_dimmer to 0

He does not have a ton of devices, a couple z-wave switches and these zigbee outlets. Do you think it would be worth the effort to roll back to an earlier release prior to the autoupdate update or are you aware of any workarounds?

I’m not aware of any workarounds, but you might want to test out the latest zigbee binding and libraries to see if that might help. Maybe play with the Item’s autoupdate settings. This may not be caused by the autoupdate change though.

This is maddening. I finally discovered the autoupdate setting in the item config. Must have overlooked it umpteen times re-adding the item.

If I set it to “Veto an auto update” I can’t get the item state (edit: better said, the item state does not update) so if I set up a switch in habpanel it will never turn on… its in a constant OFF state. “Enforce an auto update” is the default I think because it just flips the item off whenever it polls.

Noob question. Do I need to switch to the 2.5.0 snapshot to get the latest zigbee binding and libraries or can I download the latest jar and install in 2.4.0? If so, where can I get the latest binding?

Usually, it is not necessary to upgrade the core (unless the binding developer is using some new functionality that is only available on the snapshot core). I doubt that this is the case between 2.4.0 Stable and 2.5.0 Snapshot (not much time has passed since 2.4.0 Stable was released).

You can grab the latest snapshot build of the ZB binding here: https://ci.openhab.org/job/openHAB2-Bundles/lastSuccessfulBuild/artifact/bindings/org.openhab.binding.zigbee/org.openhab.binding.zigbee/target/

Uninstall the 2.4.0 ZB Binding from PaperUI, download 2.5.0 ZB Snapshot jar, place it in addons

check from the console if it loads correctly (and becomes Active)

There’s a bit more to it for zigbee, because you also need the libraries and bridges…

I’m doubtful that upgrading will help, since not much has changed since last week. Rather than manually installing the binding, I suggest using a snapshot build, in case there’s a deeper issue.

1 Like

I was able to successfully upgrade to the 2.5.0 snapshot and 1.1.7 libraries (previously installed libraries were 1.1.6). Unfortunately nothing has changed and my issues persist with this dang outlet. I can turn it on/off in my node-red sequences so I have that going for me but I can’t base anything off of current state since the switch item is always off. I’m throwing in the towel for now. Thanks for all the info/guidance. It is much appreciated.

2 Likes