Snapshot miss-match 'openhab-distro' vs 'openhab2-addons'

Hi openhab forum,

first of all - this is a great endeavour I am highly appreciating the effort of this community.

I am new to openhab2 and have just recently started to move my smarthome efforts to openhab2. Home automation based on openhab2, controling my KNX infrastructure is working fine.

At the moment I am trying to better understand the internals of bindings and things, as well as the entire JAVA framework. I have set up eclipse and pulled sources from github as described by Kai:

  • openhab-core
  • openhab-distro
  • openhab2-addons
  • smarthome

Eclipse threw ‘thousands’ of errors and warnings and did produce any JARs at all. Quitting eclipse and building everything with ‘mvn clean install’ worked in the end. Restarting eclipse afterwards gave a different picture, the error/warnings where gone. (searching the web gave me the impression, that this happend to serveral people, thus my question: how can this be avoided? Any hint how to settle this with eclipse allone would be highly appreciated.)

Next thing I tried was creating my own binding sceleton with ‘’. The script creates a pom.xml with reference to ‘2.0.0-Snapshot’ whereas the entire sourcetree of openhab2-addons is already on 2.1.0-Snapshot. The binding compiles correctly.

While trying to test my primitive binding according to Kai’s video it turned out that the new binding doesn’t load, since it is based on the wrong Snapshot.

Who can I fix this? Sorry for the lengthy post and many beginner questions (and starting off in German :blush: ) …

Any hint would be highly appreciated.



Sorry Klaus, you might get more feedback if you post in english. This is not a german community.