Snapshots starting with 2.5.0~S1568-1 broke JSONDB parsing

Tried to understand the Thing db.
From the errors it is often Expected BEGIN_ARRAY but was BEGIN_OBJECT at path $.channels[0]

What I find is that the HUE things now contain channel definitions which are not formatted as array of objects but directly as object. Ok, they seem to be single objects so actually not really an array but does the jsondb implementation still expect an array?

All affected things (with channels) are HUE items if that helps anything.

@cweitkamp I suspect that this broke through as the storage is using the Thing objects (and unfortunately not the DTOs), which have been changed in that PR.

@Wolfgang_Rosenauer May I ask you to enter an issue about it at Thanks!

Opened an issue on github.
Also downgraded to snaphost 1566 which seems to give me pretty much my system back from a first look. (That means snapshot 1568 already shows the issue for me; not only 1569)


Update to 1569 broke all Zwave things => they are gone. Re add stick and notes: Zwave fine. Edit one of that things: error 409 conflict (think with same thing from version 1562 not deleted and not shown anymore)
Will go back to 1562, because 1566 kills zwave (unititialised) too

I did not see that one coming. Will provide a fix for it or revert the changes in the Thing / Bridge objects. Sry for inconveniences.

1 Like

Same issue. I am on the #1566. Just loosing the settings of the zwave controller when restarting the RPi. Every Zwave Thing is found again at every restart. All settings of other bindings are there.

PR is in place:

1 Like

So how can i get this update? Nothing in my openhab is working after i updated a couple of hours ago…

1570 should be her tomorow then ? :stuck_out_tongue: thanks a lot !

Same here.
reverting to m1 make my install really unstable.

I have mannually isntalled openhab , i was easier for me to manage ( except in this rare scenaro)…so i can’t get back to 1566.

Does anyone has a oh2 snapshot 1566 zipfile?

That’s really sad. So we are back on the old, slower implementation with the revert.

Is’nt there a update every 24 hours? Was hoping for a fast fix so i can get my system up and Running again :blush:

Should not be too long :stuck_out_tongue:

Good :blush:

1570 is ready. And the issue is solved .

-add your thing back in 1570. restart oh


Unfortunately we are. I will look into the root cause.

No, not really. Even the snapshot build has to be triggered manually.

Good to hear.

2.5.0~S1571-1 seems to still be very broken. All of my zwave devices are showing up in the inbox, and uninitialized.