SNMP binding does not work

i am new to openhab2 and I want to get data via snap from my synology disk station.
I installed snmp on the raspberry where openhab runs on. On the raspberry (terminal) I can successfully get snap data from the device, but on the openhab log I get “2018-03-26 17:18:51.108 [ERROR] [ab.binding.snmp.internal.SnmpBinding] - SNMP: snmp not initialised - aborting request”
I tried everything I found here in the community, but it doesn’t work.
The port in the openhab snap config is 162. Trapd config forwards to 162.
Does anyone has an idea?


Check your SNMP configuration on the Synology NAS first. Then trying doing an snmp walk from the OH server and see if it can view all of the data.

Snmpwalk and snmpget for the nas oids
works fine on my raspberry.

Is OH installed on the same NAS? If not then can you try an snmpwalk from the OH server. We need to find out if you have a connectivity issue or a configuration issue.

Hi the OH is installed on a raspberry pi. Snmpwalk on the oh server works fine. I get the requested oid values from my sinology nas.

Thx for your answer.

Does this mean your problem has been resolved? If so then please mark this thread as being resolved, this is to help others who may find this thread from a search.

No it has not solved my problem. I don‘t understand why the snmp binding does not work although the snmpwalk and -get works on the open hab server.

Any ideas?

When starting open hab Server i get the following error in the openhab logfile:
SNMP Binding couldn‘t listen to
Does anyone know why this error occures and Howe to solve it?

So I have solvent the problem! The Problem was the Port 162 in the snmp config. I changed it to 1600 there and added the Port also to the snmptrap.conf. And now it works fine.