[Solved] 2/10/2017 ZWave Binding Broke ALL Switch Things

Oh I tried that a few times but it didn’t pull down the latest. Even restarted openhab but still on binding.

Have you installed from a package (eg apt) or manually? I wonder if that restricts things (I’m not sure though).

I’ve just kicked off a new build to see if that helps.

I installed openhab2 using apt following the instructions on the wiki. I am wondering if the bindings are not getting updated because there wasn’t a build of the main openhab distribution last night, so it is trying to keep everything on

The linux distro is set to only build manually at the moment it seems. Currently the system is rebuilding - once this is done I’ll kick off the linux distro build and hopefully it will sort itself out in an hour or two.

excellent! Thanks for the help.

Try now…

That worked!
A ‘apt upgrade’ of openhab2 caused the binding to be updated and now all my lights are working again.


1 Like

Thanks :slight_smile:

I can also confirm that the update fixes the switches on my system as well. Thanks for all your support.

Works for me, I updated the original post with the solution, thanks for your help.

how do i update to the last binding i am using openhasbian and i dont work whit uninstall and wait 30 seconds and instal it again

It depends:

If your are on the stable release: uninstall the zwave binding, download the snapshot zwave binding, add the .jar to your addons folder.
You also could upgrade openHABian from stable to snapshot release.

If your are on a snapshot release: uninstall binding, wait, install binding.

wher do i find the snapshot zwave binding


now i copy the org.openhab.binding.zwave-2.1.0-SNAPSHOT.jar into /usr/share/openhab2/addons what do i do now in the paperUI i dont see the binding

Log into your karaf console, do a bundle:list and see if the binding is active:

204 | Active | 80 | | ZWave Binding

244 | Installed | 80 | | ZWave Binding

is say installed but ther is not one Active | 80||ZWave Binding most ther be that

Okay, installed, but not ACTIVE.

Do a bundle:start org.openhab.binding.zwave

i get this error

Error executing command: Error executing command on bundles:
Error starting bundle 244: Could not resolve module: org.openhab.binding.zwave [244]
Unresolved requirement: Import-Package: gnu.io