[solved] Activating HabPanel uninstalls bindings

As i wanted to try out HABPanel i added habpanel to the list of ui in servicesaddons.cfg.
After saving the file to the server habpanel started and uninstalled my other bindings and persistence.
Why does this happen?

2017-01-14 13:01:47.576 [INFO ] [panel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel
2017-01-14 13:01:50.218 [DEBUG] [health.internal.NetworkHealthBinding] - couldn't establish connection [host 'giant' port '0' timeout '5000']
2017-01-14 13:01:52.810 [INFO ] [core.karaf.internal.FeatureInstaller] - Uninstalled 'openhab-persistence-jdbc-postgresql'
2017-01-14 13:01:57.387 [INFO ] [penhab.io.transport.mqtt.MqttService] - Stopping broker connection 'mosquitto'
2017-01-14 13:01:57.518 [INFO ] [core.karaf.internal.FeatureInstaller] - Uninstalled 'openhab-binding-mqtt1'
2017-01-14 13:02:02.232 [ERROR] [org.openhab.binding.tcp             ] - [org.openhab.binding.tcp.protocol.tcp(190)] The deactivate method has thrown an exception
        at org.openhab.binding.tcp.AbstractSocketChannelBinding.deactivate(AbstractSocketChannelBinding.java:727)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)[:1.8.0_111]
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)[:1.8.0_111]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)[:1.8.0_111]
        at java.lang.reflect.Method.invoke(Method.java:498)[:1.8.0_111]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)[:1.8.0_111]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)[:1.8.0_111]
        at java.lang.Thread.run(Thread.java:745)[:1.8.0_111]
2017-01-14 13:02:02.406 [INFO ] [core.karaf.internal.FeatureInstaller] - Uninstalled 'openhab-binding-tcp1'
2017-01-14 13:02:05.227 [DEBUG] [health.internal.NetworkHealthBinding] - couldn't establish connection [host 'frodo.fritz.box' port '0' timeout '5000']
2017-01-14 13:02:05.232 [DEBUG] [health.internal.NetworkHealthBinding] - established connection [host '' port '0' timeout '5000']
2017-01-14 13:02:06.990 [DEBUG] [org.openhab.binding.networkhealth   ] - ServiceEvent UNREGISTERING - {org.osgi.service.cm.ManagedService}={service.pid=org.openhab.networkhealth, component.name=org.openhab.binding.networkhealth.binding, component.id=187, service.id=321, service.bundleid=235, service.scope=bundle} - org.openhab.binding.networkhealth
2017-01-14 13:02:07.012 [DEBUG] [org.openhab.binding.networkhealth   ] - ServiceEvent UNREGISTERING - {org.openhab.model.item.binding.BindingConfigReader, org.openhab.binding.networkhealth.NetworkHealthBindingProvider}={component.name=org.openhab.binding.networkhealth.genericbindingprovider, component.id=188, service.id=319, service.bundleid=235, service.scope=bundle} - org.openhab.binding.networkhealth
2017-01-14 13:02:07.035 [DEBUG] [org.openhab.binding.networkhealth   ] - BundleEvent STOPPING - org.openhab.binding.networkhealth
2017-01-14 13:02:07.038 [DEBUG] [alth.internal.NetworkHealthActivator] - NetworkHealth binding has been stopped.
2017-01-14 13:02:07.044 [DEBUG] [org.openhab.binding.networkhealth   ] - BundleEvent STOPPED - org.openhab.binding.networkhealth
2017-01-14 13:02:07.053 [DEBUG] [org.openhab.binding.networkhealth   ] - BundleEvent UNRESOLVED - org.openhab.binding.networkhealth
2017-01-14 13:02:07.063 [DEBUG] [org.openhab.binding.networkhealth   ] - BundleEvent UNINSTALLED - org.openhab.binding.networkhealth
2017-01-14 13:02:07.146 [INFO ] [core.karaf.internal.FeatureInstaller] - Uninstalled 'openhab-binding-networkhealth1'
2017-01-14 13:02:10.241 [DEBUG] [health.internal.NetworkHealthBinding] - couldn't establish connection [host 'giant' port '0' timeout '5000']
2017-01-14 13:02:20.244 [INFO ] [b.core.service.AbstractActiveService] - NetworkHealth Refresh Service has been shut down

I’m on the latest openhab2 installed with apt-get from bintray unstable release.

This goes on.
I have tried to reactivate the persistence service jdbc and the bindings through karaf by using feature:install, but i could not find the networkhealth feature (1.9). Then i tried to install the networkhealth binding via paperui.
Following the install of the networkhealth binding, all other bindings and jdbc persistince service are uninstalled again.

Have you added any configs regarding bindings, persistence, etc in addons.cfg? If so - verify that all of your bindings etc are specified there.

Just a thought…

my addons.cfg

# The base installation package of this openHAB instance
# Valid options:
#   - minimal  : Installation only with dashboard, but no UIs or other addons
#   - standard : Typical installation with all standards UIs
#   - demo     : A demo setup which includes UIs, a few bindings, config files etc.
package = expert

# A comma-separated list of bindings to install (e.g. "sonos,knx,zwave")
binding = http,mqtt,networkhealth,tcp

# A comma-separated list of UIs to install (e.g. "basic,paper")
ui = basic,paper,classic,habpanel

# A comma-separated list of persistence services to install (e.g. "rrd4j,jpa")
persistence = rrd4j,jdbc,influxdb

# A comma-separated list of actions to install (e.g. "mail,pushover")
action = 

# A comma-separated list of transformation services to install (e.g. "map,jsonpath")
transformation = map,jsonpath,javascript,regex

# A comma-separated list of text-to-speech engines to install (e.g. "marytts,freetts")
tts = 

# A comma-separated list of miscellaneous services to install (e.g. "myopenhab")
misc = 

Reinstall via paperui brings all up again, but why this behaviour?

I consider this solved.
The lesson i learned is not to switch to different configuration schemes.
I had mixed expert mode via config files and configuration via paperui.
I have since switched to standard mode and only kept item, sitemaps and rules from 1.8.

HabPanel was not the cause of this.

Help! I have the same problem.

What do I do? I use only via paper UI? Do I remove it from addons.cfg?

Or the other way around?