[SOLVED] Add-ons page empty in PaperUI

Running OpenHAB2 on Arch Linux 4.19.13-1-lts.
Upgraded yesterday to openhab2 2.4.0-1.
When calling afterwards, I cannot see any add-ons.
Changed to package = standard instead of minimal in /etc/openhab2/services/addons.cfg,
and rebooted the machine, but did not help.

Any hint appreciated.

Best regards

I’ve had this happen in the past on version 2.3 and doing a refresh or closing the page and reopening seemed to solve the issue.

Since upgrading have you tried cleaning the cache then rebooting?

Clean cache for apt-get installs:

sudo systemctl stop openhab2

sudo openhab-cli clean-cache

sudo reboot
or if you prefer not to reboot
sudo systemctl start openhab2

1 Like

Cleaning the cache was the right advice!!!
Not sure how this works with openhab-cli clean-cache, after you stopped the service, but anyhow:
Just removed both
completely and magically all the add-ons were visible again in PaperUI after restart.
Unfortunately, I then had to re-install all my add-ons which caused some headache here and there.
Maybe I should put them all into addons.cfg and see whether this helps the next time.

As of now, many thanks!!!

It does the same thing as manually cleaning both of those files. If you prefer to do it manually you should always stop the OH service first.:wink:

Never had that issue but I’ve been using openhab-cli clean-cache instead of the long way for some time now. FYI openhab-cli can also make a backup for all your configs.:+1:

Glad you have it working.:fireworks:

If you would please mark the topic solved by clicking the square box on the post that provided the solution and edit the title to start with [Solved]. This will help others with a similar issue find a quick solution.


Thanks again!