[SOLVED] Addons/Addon-management not visible in PaperUI

I am running the openhabian on Raspberry Pi 3.

I have updated the openhabian to the latest version.

From the past week, I cannot see the Addons option in paperUI.
I have also checked HABmin UI. The “Extensions” option is visible in HABmin. But, when clicked, it says “error retrieving extension list” .

I tried rebooting the system, Clearing browser cache ,reinstalling the addons using apt-get and also adding .kar file to the addons folder. None of the above are working.

Kindly help if anyone has faced the problem before.

Thanks in advance.

UPDATE: I have tried installing bindings using CURL, Bundle install too. None of those are working (openhab 2.1.0 release version) . Kindly help @Kai

UPDATE2: I cleared /var/lib/openhab2/cache and /var/lib/openhab2/tmp folders and rebooted the Pi. Now I can see everything including the installed add-ons.

1 Like

Can you call


What means the latest version, 2.1 or snapshot #10xx ?
Try to remove the addons\*.kar.


I tried it. I can see just Add-ons heading. Rest everything is blank. It says Error 503 Service Unavailable.
And yes. I removed the .kar file too.

FYI I also tried using Rest API .But no luck :neutral_face:

In openhabian-config you can do
01 | Update
02 | Upgrade System
11 | Packages
14 | Fix Permissions
41 | openHAB 2.1 stable / openHAB 2.2 unstable (switch)


I tried everything you have mentioned and rebooted the system.
The problem still persists.