[SOLVED] Aeon Nano Switch with energy meter: Unknown device

Hi there,
I added a the above mentioned device to my z-wave network, but still “Unknown Device” is shown.
Following some hints in the forum I uninstalled and reinstalled the z-wave binding. This did not solve the problem.

here the data:

Paper UI:
zwave_class_basic ROUTING_SLAVE
zwave_class_generic BINARY_SWITCH
zwave_frequent false
zwave_version 1.1
zwave_listening true
zwave_plus_devicetype ON_OFF_POWER_SWITCH
zwave_deviceid 116
zwave_nodeid 11
zwave_routing true
zwave_beaming true
zwave_class_specific POWER_SWITCH_BINARY
zwave_manufacturer 134
zwave_devicetype 3

manufacturer 0086 " Aeon Labs"
type 0003:0074

Any suggestions how to solve the problem? Is the device not in the database?


You make look yourself at:

You will find:


Now you need to find out which zwave binding version you are running: if it is too old that device may not work. If it is a battery operated device you need to wake it up several times.
To find out the version use the karaf console and do a bundle:list.


ok, that seems to be the device.
Ööööh: What is a karaf console and how can I make use of it?
(sorry - I startet to work with OH2 about 1 month ago :roll_eyes:)

When I uninstall and reinstall the z-wave-binding (as I did) - shouldn’t it be the newest version then?



ah - ok: I found it.
z-wave binding is Version 2.1.0

is there a newer one available?

Still Unknown Device :disappointed_relieved:

Yes: 2.2 snapshot: https://openhab.ci.cloudbees.com/job/openHAB2-Bundles/lastSuccessfulBuild/org.openhab.binding$org.openhab.binding.zwave/

As long as you are on a stable release: no. That would only work on snapshot releases.

Yes, it looks like you need 2.2. This was added on July 24th, which is after 2.1 was released.

This worked!!

Great - thanks a lot!!

1 Like