[Solved] Aeron Labs DSB05 Multi-sense nor reporting motion events

I’m not getting motion events from an Aeron DSB05 Multi-sensor. I was able to get the DSB05 included (low power mode seemed to be the key) and I’m able to get temperature, luminance, humidity and battery fine but I don’t get any motion events. For the Configuration Parameters, I set 4. Motion Sensor to Enabled and I’ve tried both “Send Basic Set” and “Send Sensor Binary Report” for 5. Command to send when movement. I don’t see anything coming through in the log files and I setup a basic rule for add’l logInfo if there is an update to the device and it’s not firing either.

Any other thoughts or suggestions on how to configure / troubleshoot?

1 Like

Have you seen any progress with the Aeotec 4in1 sensors in OH2?

Have 3 of them and one 4in1 G5 type and all of them do not fire motion events after switching to OH2 (from OH1 1.8.3 before). All other sensor data like hunidity, temp etc. are correct.

I also do have Evespring SP103 and Fibaro FGMS001 as well as the AeoTec 6in1. All of them are triggering motions perfectly.

Running on a NUC N2830 with Ubuntu 15.10 and Oracle Java

I have not made any progress. I did see in the ZWave discussion that @chris is working on some of the alarm channels. I installed a nightly last week but haven’t seen any change in behaviour. Was going to uninstall / reinstall when I get a chance to see if makes any difference. Glad to hear that it’s not just an issue with my installation.

Maybe I’ve found the reason. In Chris Jackson’s Z-Wave database, there are no checkmarks in the endpoint sections for DSB05 and ZW074 so there’s probably no junction between SENSOR_BINARY and BASIC (Command Class):

For reference here’s the same section for Everspring SP-103 (simple PIR sensor), SENSOR_BINARY is checked for the BASIC command class. (cannot put more than 1 image as new user so just belive me)

Would be great if Chris could check if this is the reason that Aeon MS4in1 sensors do not report any motion in OH2 (whereas they work well in OH1)

I’m not familiar enough with the structure of the binding but that sounds like a probable cause. @Chris your thoughts? Thanks.

@TeeVee So I made the edit to the database and submitted it for review. Hopefully it will get included in a build in the next day or two and we can test.

Great, really appreciated. Could you please also amend ZW074 - This is the AeoTec M4in1 (G5) which looks identically to M4in1 but has Z-Wave+ I also have one of this type and it shows same behaviour (and same missing checkmark in the dataabase). Once again many thanx!
As soon it’s processes I will check and post my findings here.

I’m a little nervous to start making a bunch of edits until we verify that’s the issue since I’m not 100% comfortable with the structure. My suggestion is that we see how the Aeron behaves and if it fixes the issue then we can submit the same fix for the ZW074.

Also, if you go to http://www.cd-jackson.com/index.php/zwave/zwave-device-database Chris’s email is on the bottom and you can ask him for edit access to the database.

Checked it this morning with the latest nightly OH2 build. My DSB05s (3 x) are now reporting motion events BUT I had to switch from BASIC_SET to SENSOR_BINARY however didn’t double check as I ran out of time. Anyway it looks good and we are probably on the right path.

That’s great news. I won’t have a chance to test until this weekend. I’ll make the edit to the other sensor later this morning so you can test it too.

@TeeVee I had a few minutes this morning so am testing the new binding (I just updated the binding, not all of OH2) and updated the ZW074. BTW, what are you using in your rules to pickup the change in status? I was just checking to see if the Item Changed (when Item Motion_SF_KidsBath changed) in my test rule? Also, are you seeing the trigger event come through in your log files because I am not (wondering if maybe it was something in the core OH2 code vs. the binding that got it working on your side). Though I did see it registering “Triggered” at one point in Habmin though on further testing it doesn’t seem to be going back to that state. So not sure…

So, I didn’t have patience to test more of just the binding and updated OH2 tonight to latest snapshot. I’m clearly seeing the status in Habmin change from Untriggered to Triggered on motion. I still don’t see anything in the logs other then device updated but it does that multiple times whether or not there is motion. I also can’t figure out the rule condition state to recognize the motion I’ve tried checking for changes to “ON”, “OPEN”, and even “TRIGGERED” All w/o causing an action to occur. @TeeVee Any luck on your side with rules?

Updated OH2 this morning so changes regarding ZW074 should be included. However MS4in1 (G5) still does not fire any events. However MS4in1 still are working and also are functional in rules.

Did you change item type from “contact” to “switch” when migrating from OH1 to OH2?

Here’s an example of my item definition:

/* MS4in1-4 */
Switch MS4in1_04_Motion “MultiSensor4in1 4 - Bewegung [MAP(motion.map):%s]” (gASt23_SG_Eingang,gAllMotion) {channel=“zwave:device:bae2b5f5:node22:sensor_binary”}

And here’s a rule using these items:

rule "motLightOn"
Item SP103_01_Motion changed from OFF to ON or
Item MS4in1_01_Motion changed from OFF to ON or
Item MS4in1_02_Motion changed from OFF to ON or
Item MS4in1_03_Motion changed from OFF to ON or
Item MS4in1_04_Motion changed from OFF to ON or
Item MS6in1_01_Motion changed from OFF to ON or
Item Fibaro_01_Motion changed from OFF to ON or
Item DevoloDoor_01_Contact changed from CLOSED to OPEN or
Item DLink_01_Contact changed from CLOSED to OPEN
sendCommand(SS6_01_Switch, ON)

This rule works without any problems.

Now still have to evaluate why my MS4in1 (G5). I suspect has something tio do with assouciation groups as there are 5 in Habmin for the G5 while there is only 1 in Habmin for the normal MS4in1.

Bingo. I had seen some other discussion in another thread about switch vs. contact but didn’t test that. With the change everything is working on my end. Thanks!!!

It may not have made it through review and into the Zwave binding when that snapshot was ran. You can update just the binding by putting it in the addons folder (you used to have to disable the internal version but not sure if that is still the case, you can verify from the console which version is loading). Here is where you can get the nightly zwave snapshots - https://oss.jfrog.org/artifactory/oss-snapshot-local/org/openhab/binding/org.openhab.binding.zwave/2.0.0-SNAPSHOT/