(SOLVED) After a restart, most Zwave nodes are stuck on REQUEST_NIF

Tags: #<Tag:0x00007f616e977648>

So today i’ve been fighting with OpenHAB for a bit.

It’s worked perfectly before, but now almost all the nodes if not the entire set of nodes start saying

‘zwave:device:72000c57:node4’ changed from OFFLINE (COMMUNICATION_ERROR): Node is not communicating with controller to ONLINE: Node initialising: REQUEST_NIF

And this has been going on for several hours now. The system has been slow to respond and most of the time lights do not respond at all.

What would be the fix for this? I’m using the latest OpenHABian and the latest OpenHAB 2.4.0.

Thanks!

How many nodes do you have, and how many of those are battery powered devices?

Around 18 nodes, none of which are battery powered.

I would guess that the issue is with your ZWave controller, since that’s the common link and your software hasn’t changed. What kind of controller are you using?

An aeon labs Gen5 stick.

What happens if you unplug/plug it? That should restart the service. You can also do a soft reset from the thing properties in PaperUI if that’s easier.

Things still are slower than normal, and the issue still persists where nothing seems to work, no matter if i unplug the stick or soft reset it.

Yuck. The only other thing I could think of is to clear the cache via SSH, but I’m only getting started with ZWave.

sudo systemctl stop openhab2
sudo openhab-cli clean-cache
sudo systemctl start openhab2

Sorry I can’t help more!

Did that already, no dice sadly.

Sounds like it might be a hardware failure. Hopefully someone with more experience can chime in with other ideas.

I did replace the SD card and restored a backup. Perhaps the backup is what’s corrupt? Though this would mean starting from scratch all over again.

I think that your ZWave stick might be failing. If you used a fresh SD card with a backup from a period when OH was working properly, the same issue shouldn’t immediately reappear.

The backup was actually from when it was failing, actually…whoops.

So knowing that, and knowing that i do not have a working backup…would i have to start anew or can this be salvageable?

I would start by uninstalling the ZWave binding to see if OH returns to normal. If other devices are fine, then you don’t need to start over completely.

If you confirm that it’s just a ZWave problem, you could try installing the ZWave 2.5 snapshot binding to see if that helps. If it doesn’t, then there’s a good chance you need to replace your USB stick.

Also, do you have HABmin installed? From other posts, it sounds like a lot of people prefer that for managing ZWave, and you can see a map of your ZWave network. Maybe it can tell you more.

I have that installed, yes.

It doesn’t tell me much that I don’t already know.

What changed? I sounds like your devices are having trouble communicating with the controller. Have you moved or removed any devices, or moved the Pi? Healing or reinitializing the nodes may help. There is also a nightly network wide heal (IIRC at 2AM).

Did you upgrade to 2.4, or have you been using this version the entire time since including your nodes?

In order to troubleshoot this in depth, you’ll need to look at some zwave binding debug logs.

It’s been at 2.4 ever since, and nothing has been moved. Healing or reinitializing the nodes hasn’t done anything to fix it.