[SOLVED] Alexa Echospot TTS - item problem


I’ve a weird problem with the TTS.

If I create an Amazonecho TTS item by paperui, its works perfectly, but if I create the item manually it doesn’t works and I don’t know why. :frowning:

here is my configuration:

things file:

Bridge amazonechocontrol:account:account1 “Amazon Account” @ “Accounts” [amazonSite=“amazon.de”, email=“MYEMAIL”, password=“MYPASSWORD”, pollingIntervalInSeconds=60]
Thing echospot Echo_Schafzimmer “Alexa” @ “Schlafzimmer” [serialNumber=“MYSERIAL”]


Switch Test_Einaus

String Alexa_Sprich “Text to Speech” {channel=“amazonechocontrol:echospot:account1:Echo_Schlafzimmer:textToSpeech”}

rule “Test Alexa”
Item Test_Einaus received command
Alexa_Sprich.sendCommand(“Willkommen zuhause”)


    Switch item=Test_Einaus label="Test_Alexa"

If I create the item via paperui, the json ChannelLink File contains this:

“Alexa_Textausgabe -\u003e amazonechocontrol:echospot:account1:Echo_Schafzimmer:textToSpeech”: {
“class”: “org.eclipse.smarthome.core.thing.link.ItemChannelLink”,
“value”: {
“channelUID”: {
“segments”: [
“configuration”: {
“properties”: {}
“itemName”: “Alexa_Textausgabe”

Any ideas? Please help. Thanks in advance!

Typo, missing “l” in “Schafzimmer”

Oh! Thanks a lot for this advice… I corrected this typo, but it still doesn’t work and there are no errors in the logs…

Have you tried without double quotes like this: (‘Willkommen zuhause’)

its works :slight_smile: Thank you all!