[Solved] Alexa won't find any items

Hi Guys,

since my first assumption was wrong ([SOLVED] Remove Tags from items), i’ve decided to create a new thread, since I couldn’t find a solution in all of the other threads with this topic.
I am running OpenHab 2.3 (release) on an Raspi model 3.

I’ve just got a fire hd tablet and currently i am trying to get the alexa skill working.

  • Connection to myopenhab is working (i am able to access the REST API from myopenhab.org/rest/items
  • Alexa skill is installed and it is also listed as an application on myopenhab.org
  • I currently have ONE item (for debugging i’ve deleted the other items) which i am trying to control:
Switch AlexaTest "AlexaTest"  [ "Lighting" ]

The REST API from myopenhab.org lists also this item:


But still, the alexa skill is unable to find this item.
I am stuck now, since i have noe idea what could possibly be wrong.

FireHD Tablet is on the same network as the openhabian setup, and openhab is running on port 8080.
Any advice would highly be appreciated.

When you login to my Openhab is the item showing in the items tab? (Note you have to toggle it in the sitemap for it to show)

If not you can expose it in the paper ui under the config for openhab cloud. (Configurations—services–io) Also in that same spot make sure the setting with remote is correct. (Notifications and remote access)

Lastly, you do have the openhab skill installed and connected under the alexa skill tab? This can be confirmed in my openha b also.

Thanks for your answer.
Exposing should not be needed anymore for the alexa skill.

Finally it is working - for god knows why
That crappy Alexa app sucks. I can’t add new devices by clicking on “Search”, but when I say “Alexa find devices” all of them appear now.

So it seems to work now :slight_smile:

1 Like