[SOLVED] Amazon dash button: Steps for a complete setup

as described in the docs: I stopped at the last step within the amazon app. After that, it worked for a day or two…

Maybe DHCP gave it a new IP? Have you tried a fixed IP for the dashbutton?

@binderth SendArpRequest is a .class inside pcap4j-sample.jar.
Maybe the only thing is missing is: pcap4j-sample.jar. But I don’t know if you can find one which is corresponding to your installation. You can find it e.g. here:

https://mvnrepository.com/artifact/org.pcap4j/pcap4j-sample.

I guess version 1.6.6 is fitting to your pcap4j-core-1.6.6.jar

Then your command could be (but I don’t really know!!) like this:

java -cp pcap4j-core-1.6.6.jar:pcap4j-packetfactory-static-1.6.6.jar:pcap4j-sample-1.6.6.jar:jna-4.2.1.jar:slf4j-api-1.7.12.jar org.pcap4j.sample.SendArpRequest 192.168.178.60

or

java -cp pcap4j-core-1.6.6.jar:pcap4j-packetfactory-static-1.6.6.jar:pcap4j-sample-1.6.6.jar:jna-4.2.1.jar:slf4j-api-1.7.7.jar org.pcap4j.sample.SendArpRequest 192.168.178.60

@binderth

Maybe this is why your dash button doesn´t work anymore?

What is your Model No. ?

I bought 5 new Dash Buttons (in Germany) 4 weeks ago. They are all running! But I had to add them manually. I just filled in the MAC-Address!

Can you tell me how you will use the buttons? I have some dash buttons running and no ideas where I can use them everywhere.

I use them all as a switch. For turning on/off: Lights, Hifi, Wifi-Sockets, switching actions for Harmony Hub, and so on…

Did you add them in the PaperUI as Things?
I configured them solely via config-files - After some digging into the case, I learned, the binding doesn’t need the dash buttons as a Thing, just in a rule, so I deleted them from my .thing configuration file and only have them in the rules - but as expected this didn’t change anything… They don’t fire as they did just after the Installation…

I don’t think mine go into factory reset or anything - as the appear online in my Fritz.Box UI and I can ping them, if activated - so I assume some configuration issues within OH2…
My model numbers are also JK29LP for the five new ones - the old ones are glued to my washing machine and dryer and I don’t want to remove them! :wink:

Did you add them in the PaperUI as Things?

Yes, I configured them via PaperUI. I don’t have a .things file for my Dash Buttons. My older ones were detected by searching in inbox (PaperUI -->inbox --> “Search for things” --> “Amazon Dash Button Binding” --> Pressing my new Dash Button once --> then it was detected automatically and shown in inbox -->click on the blue hook --> add as thing.
My newer ones: I had to do an other procedure: PaperUI --> inbox–> “Search for things” --> “Amazon Dash Button Binding” --> Pressing my new Dash Button once -->nothing is shown in inbox -->Add manually --> “Amazon Dash Button” --> Configuration --> Select network interface --> fill in MAC-Address! MAC-Address format is: 00:80:41:ae:fd:7e That’s it!

1 Like

This is wrong. You don’t need any items, but you definitely need a thing, either via autodiscovery or via manual thing file.

See also: http://docs.openhab.org/concepts/index.html

moin,
I have the same behavior, the dash button dont appear in the inbox, but work, if I add it manually. That works for me, but did anybody know, why it dont appear in the inbox?
Its just for my curiosity.

@ktams I guess it depends on the MAC-ADDRESS. If the pattern is not matching then you have to add it manually.

Yes, I’m right, see here:

Line 59 ff

The newer ones have other MAC-Addresses…

@oliver Do you know about this? New Amazon Dash Buttons have new MAC-Addresses! Automatic detection is not working!

My new ones begin with:

b4:7c:9c
68:37:e9
fc:a6:67
18:74:2e

Could you please insert them into AmazonDashButtonDiscoveryService.java ??

Thanx a lot!

moin,
ok, I see. My buttons begins also with 68:37:e9

@ktams see also this: issue-2444

Thanks for the heads up. confused :confused: as I was! :wink:

in the meantime, I digged deep and after some hours comparing the prod setup with my test setup (where I successfully managed to install the dashbuttons), I found out, that on my prod setup somehow the libpcap-installation was removed. I’m not sure, how this could happen. At some stage I used “apt-get autoremove” for some unused package… But I never explicitely removed libpcap. After reinstalling and rebooting (not sure how to achieve this without reboot), it works now again as intended.

1 Like

I now use amazon dash button in another way.

Please can someone tell me, how i can remove the installed lipcap things like described in the first post?

Do i have to change the setcap command back to its previous state? How?

This is what i did to install it:

sudo apt-get install libpcap-dev
sudo setcap cap_net_raw,cap_net_admin=eip `realpath /usr/bin/java`

Is this the right command?

sudo apt-get remove libpcap-dev

Or do i have to use autoremove including dependencies?) What about revert the changes made to setcap?

Got new dashbuttin and dont come around with :frowning: !

Im on OH2.2 under Docker and the dashbutton wont show up at all :frowning:

I had the same issues of my dash button not been detected in PaperUI
Just added the dash manually with its MAC (as ID as well like described somewhere above).

REBOOT!

That’s it.