[SOLVED] Amazon Echo Control Binding

It’s a binding from the market place
You first need to enable the market place
PaperUI/Addons/Misc/Eclipse IoT Market - Install
Go back to Bindings and refresh with the round arrow thing at the top right
Then you should be able to see the amazon echo binding

that was the hint.

Binding is installed now. But still not working. I will follow this up in the binding thread.
Thanks for your help.

You should move from RC1 to the Release.

… and then the binding is available without the marketplace :grinning:

You should move from RC1 to the Release.

Thanks for the hint. I tried, but with
apt-get update / upgrade

it doesn´t install to the newest version. The system always tell me, it is already the newest version installed.
If I change manually to the specified version, I will get not info about newer version. What might be the correct solution for that?

Check your openhab2.list:

sebzim@openHAB:~ $ cat /etc/apt/sources.list.d/openhab2.list
deb https://dl.bintray.com/openhab/apt-repo2 testing main 

Look good. But there is no update available.

Nope. You are on the testing branch. You need to switch to stable for the 2.3 release or unstable for 2.4 snapshot.

You are right. But this doen´t change anything.
I tried also with stable and also again with update / upgrade.
No newer version available.

Sorry, out of ideas, I don’t use the apt repository …


sudo apt-cache madison openhab2

What do you get?

  openhab2 |    2.3.0-1 | https://dl.bintray.com/openhab/apt-repo2/ stable/main armhf Packages                                                                                                                     
  openhab2 |    2.2.0-1 | https://dl.bintray.com/openhab/apt-repo2/ stable/main armhf Packages                                                                                                                     
  openhab2 |    2.1.0-1 | https://dl.bintray.com/openhab/apt-repo2/ stable/main armhf Packages                                                                                                                     
  openhab2 |    2.0.0-1 | https://dl.bintray.com/openhab/apt-repo2/ stable/main armhf Packages

Ok so you are on the last stable release and it still doesn’t work.
Are you willing to try SNAPSHOT

echo 'deb https://openhab.jfrog.io/openhab/openhab-linuxpkg unstable main' | sudo tee /etc/apt/sources.list.d/openhab2.list

sudo apt-get update
sudo apt-get install openhab2
sudo apt-get install openhab2-addons

I want to avoid the snapshot.
Did this during the last month and I crashed my complete install in total 3 times with broken snapshots. No recovery was possible.
So I would prefer to stay with stable versions…

Did you try?

sudo apt-get --reinstall openhab2
sudo apt-get --reinstall openhab2-addons

also not working.
I tried this one

sudo apt-get install openhab2=2.3.0-1

He told me, I was doing an downgrade…
We will see, how it work. It is now installing…

Downgrading to 2.3.0-1??
You must have been on some snapshot

It was coming from here

openhab2 | 2.3.0-1 | https://dl.bintray.com/openhab/apt-repo2/ stable/main armhf Packages

It is running.
Also the Echo binding works now.
Thanks for help.


I’m running Synology openHAB Snapshot and I’m located in the US.

My Amazon Things stay in Uninitialization state

The testing URL shows this below http://openhab:8080/amazonechocontrol/

Amazon Echo Control RC3
No Account thing created

I’m concerned doing a manual Snapshot upgrade would bust the installation on Synology.

Any help would be appreciated.