[SOLVED] Amazon Echo error 409 conflict

Hello Everybody

  • OpenHab running on Synology 6.2.1

I tried to install the Amazon echo Binding without success. I have configured the Items:

Bridge amazonechocontrol:account:account1 "Amazon Account" @ "Accounts"
    Thing echo 			           echo   "Alexa" @ "Living  Room" [serialNumber="XXXXXXXXXX"]
    Thing flashbriefingprofile flashbriefing1 "Flash Briefing Technical" @ "Flash Briefings" 
    Thing flashbriefingprofile flashbriefing2 "Flash Briefing Life Style" @ "Flash Briefings" 

Then in Papaer UI, I have to set up my Account and password but I have a 409 Conflict error. I have also tried to go to the page http://openhab:8080/amazonechocontrol/account1 but every time a go back to http://openhab:8080/amazonechocontrol.


2019-01-02 07:16:46.712 [INFO ] [el.core.internal.ModelRepositoryImpl] - Refreshing model 'amazonechocontrol.things'
2019-01-02 07:17:18.593 [INFO ] [st.core.internal.thing.ThingResource] - Received HTTP PUT request for update configuration at 'things/amazonechocontrol:account:account1/config' for an unmanaged thing 'amazonechocontrol:account:account1'.

I have removed OH and reinstalled but nothing change.

Do you have an Idea ?

Thank you

The authentication page from Amazon has changed, you need to go to a snapshot binding version or maybe try the beta:

No idea if that still works with that very old 2.3 install on your system.

Hello, thank you for the new release. Now it is working fine.

Thanks a lot

Please mark the thread as solved, thanks