[SOLVED] Basic&PaperUI Umlauts not showing

My Basic&PaperUI cant show Umlauts. Both Raspi 4 and Openhabian-config are set to de_UTF-8.

If i eg create a new Room in PaperUi like “Küche”, it will show up as Küche until i reboot. After that it will display as K??che.
My BasicUi cant even show them until reboot.

Are there more settings i didnt set right?


Don’t you need DE_de (as opposed to CH_de etc.)?


I took a quick look in my openhabian-config: Actually it is de_DE.UTF-8 UTF-8.
I changed it to CH and back, but still no Umlauts.

The link you posted is broken. :confused:

Try Setting locale failed

There was a stray ` at the end of rossko57’s posted URL.

Maybe that is another typo?

yep saw that later, sorry

I found the problem: The raspi locales werent installed.

sudo apt-get install locales

Set locals afterwards and done. :slight_smile:

Thx for your help guys

That makes sense. Was there a clue, a loģged complaint about missing locale?

When setting the openhabian-config, there was something like „local language file does not exist“. So i just yolo-installed it.