[SOLVED] Basic UI: charts show strange values after update

Hello everyone,

I save my temperature with rrd4j and before my update to 2.3.0 (the latest RC) it works fine.
Now I have the some strange values ​​in the y-axis.

I already quit OH and delete the persistence file (was a hint from another thread here),
but unfortunately it did not solve my problem.

Does anyone have an idea what I can try?


Hi again,

I have to say that I investigate deeper and try to figure out what the issue is.
And after adding some more temperature values to the groupe, I saw that the other values are shown correctly and only the first one (Wohnzimmer_Temp), which I ever had before, have the described problem.

If I remove it from group, everything is shown correctly in x-axis.

Now I’m asking, what is wrong!?
All values are configured in same way:

Number Wohnzimmer_Temp 		"Temperatur Erdgeschoss [%.1f °C]" 		<temperature> 				  ["CurrentTemperature"] { channel="knx:device:bridge:generic:Wohnzimmer_Temp"}
Number GastWC_Temp 			"Temperatur Gast WC [%.1f °C]" 			<temperature> (gTemperaturen) ["CurrentTemperature"] { channel="knx:device:bridge:generic:GastWC_Temp"}
Number FlurOG_Temp 			"Temperatur Obergeschoss [%.1f °C]" 	<temperature> (gTemperaturen) ["CurrentTemperature"] { channel="knx:device:bridge:generic:FlurOG_Temp"}

In the events log and in UI I see correct values:

2018-12-30 20:32:03.621 [vent.ItemStateChangedEvent] - FlurOG_Temp changed from 22.3 to 22.2
2018-12-30 20:32:04.369 [vent.ItemStateChangedEvent] - Wohnzimmer_Temp changed from 22.8 to 22.7

knx config:

		Type number        : Wohnzimmer_Temp       			"Temperature"       [ ga="9.001:<5/5/60" ]
		Type number        : GastWC_Temp       				"Temperature"       [ ga="9.001:<5/5/30" ]
		Type number        : FlurOG_Temp       				"Temperature"       [ ga="9.001:<5/5/70" ]

Does anybody has an idea whats wrong here?

Thanks and best,

I had some similiar problem here and never find the root cause.
A simple service restart resolved the issue.
I had this issue with homematic/weather items and the mysql persistence.

kind regards

Thanks for your reply.

I‘ve fixed it by reseting the knx interface from which I receive the wrong value. Now everything works fine.