[Solved] BasicUI error displaying value

Tags: #<Tag:0x00007f6173022b10> #<Tag:0x00007f6173022890> #<Tag:0x00007f61730227c8>

Hi,

after upgrading to 2.4 the BasicUI is not showing the values of my rollershutters. The value (for example 0) is displayed as Error.

This is the error i found in the log file:

2019-01-07 11:31:29.627 [WARN ] [ui.internal.items.ItemUIRegistryImpl] - Exception while formatting value '0' of item Jalousie_Badezimmer with format '%.2f %unit%': Conversion = 'u'

What changed with 2.4? 2.3 was working fine.

Thank you

It looks like you try to convert int into an float with the %.2f part, although the %unit% part I am unfamiliar with.

Yes I guess this is a conversion error, but I don´t know where and why this is happening. I have a sitemap showing all the rollershutters:

Frame label="Gewerke"
    {
        Group item=Rolladen
    }

I am not doing any conversion on my own. So I don’t know where the “‘%.2f %unit%’” part is coming from. This is something that is happening automatically I guess.

Can you post your items and sitemap, please?

Sure. Here is the items file (excerpt):

Rollershutter   Badezimmer  "Jalousie_Badezimmer"    <blinds>    (Badezimmer,Rolladen)   {channel="homematic:HM-LC-Ja1PBU-FM:ccu2:XXX:1#LEVEL"}

and here is the sitemap (excerpt):

sitemap test label="Gewerke" 
{
    
    Frame label="Gewerke"
    {
        Group item=Rolladen
    }
    
}

Thanks for your help

Homematic issue:

So you think this is a Homematic Binding issue? If yes I will move the thread to Addons/Bindings.

Thanks

You exact problem was solved in the link I provided
It’s a combination of binding and sitemap
Lease the topic, it’s fine.
Just, maybe change the title to add Homematic rollershutters

thank you I will give it a try!

Update: Solved