[SOLVED] BasicUI refresh data issue for "ping"

Hey guys,

i added the network binding and added my phone’s IP to test some kind a presence awareness.
Now it looks to me that my BasicUI URL needs to be refreshed before detecting properly.
Example is that my phone leaves the house and it wont show it as OFF untill i refresh my browser.
Though i have seen it changing before without doing anything.

So now i am unsure of when en how this actually refreshes my data.

just thinking out loud here.
Can i make my whole sitemap refresh at certain intervals?
Or can i make this item refresh?
Or what would actually be the solution?



    Frame  label="Presence Awareness"
		Text item=Bjornphone label="Bjorn Phone [%s]" icon=network labelcolor=[OFF="red", ON="green"]   valuecolor=[OFF="red", ON="green"] 
		Text item=Bjornphonelastseen label="Last seen" icon=motion 


//Presence Awareness
    Switch Bjornphone { channel="network:pingdevice:192_168_1_3:online" } 
    DateTime Bjornphonelastseen  "Date [%1$tA, %1$td.%1$tm.%1$tY %1$tH:%1$tM]"  { channel="network:pingdevice:192_168_1_3:lastseen" }

What browser are you using?

Chrome, i can test in a different one if u like?

I’ve read about a few issues with BasicUI refreshing but no solution. I would with a few different browsers and see if it makes a difference.

It’s also been mentioned that after changing items files Openhab has to be restarted.

i’ll def. test this.
Btw when you say restart, is restarting the service good enough?


Yes, I think so but I normally don’t restart when changing items. If I need BasicUI to update I use F5 or use the refresh icon with mouse.

Also read that ClassicUI does not have this issue but I’ve never tested this.

I actually notice 2 things.
I think that indeed the interface does not update quick enough, and secondly if i turn off my wifi on my phone it still take a couple of refreshes of my browser before it knows that my phone is offline, this makes me think even the ping command or what ever is running in the back to monitor this refreshes “to slow”.

i tested this in Internet Explorer, same issue and on top it does not show my livestream camera in one of my groups.
Mozilla, Edge and Chrome are all 3 not updating without refreshing manually or by changing the group, but at least my camera’s work with these browsers.
So i restarted openhab and opened these 3 browsers on my pc with my phone connected to wifi.
Turned off wifi and waited…
10 min and nothing changed, according to my interface my phone is still connected, then i tried clicking a group and going back, it does trigger a refresh it seems.

this also makes me think if i will ever connect temperature sensors that the data is not live but only when changing groups or refreshing the interface.

How is your Phone detection setup? Sometimes when trying to detect a phone it takes multiple attempts with timeouts.
My Thing for an iPhone

Thing network:pingdevice:SiPhone [ hostname="", uses_ios_wakeup=1, uses_arp_pings=1, retry=30, timeout=15000, refreshInterval=60000 ]
1 Like

that is unfortunally another thing i need to look in to.
apperantly when creating things via PaperUI the items are found in a json database, so i dont have a things file to check. I found the file via ssh but was not able to open it.


But same thing i assume

I believe so. I have everything on my setup created in Things and Items file. When I first started using OH I read that I would need these in a file to work with rules. You can create a thing in /etc/openhab2/things directory and use the setting you have in PaperUI. Use my Things posted above as an example of how it should look.

Do you use VSCode?

i created a home.things via ssh, funny u ask about the VSCode.
I do indeed.
i dont have permissions to write in this file with this.

Same with the option it advises to retry as “Admin”

Check your samba config and try use openhabian-config to fix permissions.

1 Like

anything particular i need to find in my smb.conf ?
Because sitemap and items work perfecty btw with VSCode.

Or shall i just run the “fix permissions”?

ok i think i see what you mean permissions are root - root

ok that worked :slight_smile:

Seems odd that items and sitemap can be configured with VSCode but not Things.:thinking: Have you check what the permissions are for this file?

Fix permissions should solve the issue.

1 Like

Correct, up to testing a new Thing :slight_smile:

Ha, you posted two more times while I was trying to reply.:laughing:

Do forget to remove the Thing you created in PaperUI else you’ll have issues with duplicate things.

was thinking to just create an extra one to test, and leave my current code, if possible: p
Btw you use arpping in ur config, i have not set this up yet.
This was not yet an issue cause everything works, it just doesnt update automatically.
How i read it was becasue of sleep mode still be able to ping a device