[Solved] Binding OrangeTV (Samsung UHD 90)

openhab2
binding
items
Tags: #<Tag:0x00007f1e5c78b2f8> #<Tag:0x00007f1e5c78b1b8> #<Tag:0x00007f1e5c78b078>
(Michel CARLUEC) #1

Hello,
I’m testing openHAB2 for my magicmirror :wink:
I would like command my tv decoder (first by on/off).
There is no plugin for my decoder (Samsung UHD 90 by orange.fr) and I want command it by HTTPBinding through an API command.
For example :
http://192.168.1.10:8080/remoteControl/cmd?operation=01&key=116&mode=0
is the command to switch the power of the decoder(192.168.1.10 is the IP of my material)

:disappointed_relieved:
I have tested a file .items like this :
Switch TVorange http=">[ON:POST:http://192.168.1.10:8080/remoteControl/cmd?operation=01&key=116&mode=0] >[OFF:POST:http://192.168.1.10:8080/remoteControl/cmd?operation=01&key=116&mode=0]}
But it don’t work.

Someone for help me ?

1 Like

(Rich Koshak) #2

There is an near infinity of things that could be “it don’t work”. We need more information. Start with How to ask a good question / Help Us Help You and come back with more info.

0 Likes

(Michel CARLUEC) #3

I precise.(with my bad english, sorry)
I’m testing openHAB2 on an ubuntu 18.04
I have installed a switch for my Sonoff (with the firmware Tasmota) by the MQTT protocol. It’s run very well (with “MQTT Binding”) :smiley:
For my problem, I have saved my tv.items file in the folder /etc/openhab2/items/ .
In openHAB PaperUI, I see the item “TVorange” in the menu Configuration, but I can’t create a thing then, It’s not appear in the Control menu.
When I create a switch widget in the HABPannel interface linked with my item, the button has no effect to my TV…

0 Likes

(Rich Koshak) #4

Which version of the MQTT Binding? 1 and 2 are both very different. And only Channels that are linked to an Item will appear in the Control tab of PaperUI. Only the 2 version of the MQTT binding has Things. And you create the Things and Channels first, then link them to Items, not the other way around.

You might need to review the Beginner’s Tutorial or the Concepts section of OH. In OH the concepts go

Device <--> Binding <--> Thing <--> Item

Please show your item definitions.

Are there errors in your log?

What version of OH are you running?

How did you install it?

Like I said above, we need lots of information to help.

0 Likes

(Michel CARLUEC) #5

I have read the tutorial for understanding the OH concept.
I have installed openHAB2 with openhab2_2.4.0-1_all.deb, openhab2-addons_2.4.0-1_all.deb and openhab2-addons-legacy_2.4.0-1_all.deb
The bindings installed are:

  • MQTT binding 2.4.0 (run well with my sonoff !) it’s not a problem.
  • Network binding 2.4.0 (run well and ping my tablet ) it’s not a problem
  • HTML binding 1.14.0

When I want to create a thing by the menu “Things” on the button blue “+” and choose “HTML Binding”, nothing appear. (when i do the same operation with MQTT Binding, I see a button “Manually Add thing” and go to create my sonoff object…)

0 Likes

(Rich Koshak) #6

Why not just install using apt-get as documented in the installation instructions?

That’s because the HTTP binding is a 1.x version binding. There is no support for 1.x bindings in PaperUI. There are also no Things and not Channels for 1.x bindings. You must define Items in .items files and configure the Item as documented in the binding’s documentation.

0 Likes

(Michel CARLUEC) #7

Because I wouldn’t install the package repository.

It’s that I done : HTTP Binding
I don’t understand what’s append.

0 Likes

(Michel CARLUEC) #8

In the log files :
on event.log, when I clic on the widget in HABPannel, I have :

2019-03-06 21:05:07.780 [ome.event.ItemCommandEvent] - Item ‘TVorange’ received command ON
2019-03-06 21:05:07.782 [vent.ItemStateChangedEvent] - TVorange changed from OFF to ON
2019-03-06 21:05:08.529 [ome.event.ItemCommandEvent] - Item ‘TVorange’ received command OFF
2019-03-06 21:05:08.531 [vent.ItemStateChangedEvent] - TVorange changed from ON to OFF

and in openhab.log I have :

2019-03-06 19:04:44.310 [INFO ] [el.core.internal.ModelRepositoryImpl] - Refreshing model ‘tv.items’
2019-03-06 19:05:03.716 [ERROR] [org.openhab.io.net.http.HttpUtil ] - Fatal transport error: java.net.SocketTimeoutException: Read timed out

0 Likes

(Rich Koshak) #9

Please show your item definitions.

The error indicates the web server you are trying to call didn’t respond.

0 Likes

(Michel CARLUEC) #10

SOLVED ! :sunglasses:

http=">[CHANGED:GET:http://192
and not POST !

Pfff :crazy_face:

1 Like

(Mariusz) #11

Hello,

Where to find a list of available remote commands for that decoder?
Also, is there a possibility to get information the device status?
thanks.

0 Likes