[Solved] Bounty to move FritzboxTr064 binding to v2

Tags: #<Tag:0x00007f433a9ad218>

Hello OH Developers!

With OHv3 on the horizon for stable release later this year… and my intent to migrate to this version, I realised there is no development to move the FritzboxTr064 binding to v2. (Failed installing 'openhab-binding-fritzboxtr064')

I am offering a brand new (German) 7490 Fritzbox (valued > 200€) to the developer who makes this binding into an official v2.

I realise I am not the only user of this binding, with others expressing the wish for a v2. There a over ten forks on GitHub; maybe one is close enough to fit the bill.

Any takers? :slight_smile:

[edit] I get the conundrum, if you want to develop, but do not have a Fritzbox to test. :slight_smile: If you have contributed before or even maintain an addon/code already, and commit to seeing this through, I trust you with sending the Fritzbox upfront.

Hi,
does a V2 version still make sense as OH 3 is underway and TR064 will be supported in this version. See:
https://github.com/openhab/openhab-addons/pull/8523
Joerg

Well, for the silly old fart I am I thought any v2 binding will run on OHv3. :slight_smile:

Out of interest: Does this mean the poor folks who ported their v1 to v2 need to do it again for v3?

https://community.openhab.org/t/guide-binding-development-changes-for-openhab-3-from-2-5-x/104134

1 Like

OK, based on reading the link above, the difference between is minor. E.g. the binding could be developed for v2, which has a great user base for testing, and can be recompiled as v3. This way, users not jumping onto v3 for a while can still enjoy a v2 environment in readiness for a v3 migration. Anyway, this is not for me to say, and is just a suggestion based on the limited understanding I have of it all.

If someone would work on this it would be best base it on the version current in development with the pull request pending. Because otherwise users upgrading to openHAB 3 would need to migrate again if it uses a different thing definition.

It’s probably a bit more work than just following the guide. Because the new binding requires java 11. This means it probably uses library methods not availlable in Java 8. While openHAB runs mostly on Java 11, probably to make it useful it should be target at java 8.

If you mean by ‘official’ a version that is included with openHAB 2 than that would be difficult as there are no new bindings included in openHAB 2, only new openHAB 3 bindings are added. But it can be still installed manually.

Hmm, it was just idea; as I said, I have not much of an idea what is involved, and simply leave to to the developer(s) to take appropriate action.

1 Like

This work is already in progress.
Bounty of new use.
Case closed.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.