[SOLVED] Caldav Personal error on 2.4M4

Hi everyone!

I have been using the binding, but now I only get this error:

2018-10-10 18:42:38.897 [ERROR] [org.quartz.core.ErrorLogger         ] - Job (event-reloader.google threw an exception.

org.quartz.SchedulerException: Job threw an unhandled exception.

	at org.quartz.core.JobRunShell.run(JobRunShell.java:213) [106:org.eclipse.smarthome.core.scheduler:0.10.0.oh240M4]

	at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:573) [106:org.eclipse.smarthome.core.scheduler:0.10.0.oh240M4]

Caused by: java.util.ServiceConfigurationError: net.fortuna.ical4j.model.PropertyFactory: Provider net.fortuna.ical4j.model.property.Action$Factory not a subtype

	at java.util.ServiceLoader.fail(ServiceLoader.java:239) ~[?:?]

	at java.util.ServiceLoader.access$300(ServiceLoader.java:185) ~[?:?]

	at java.util.ServiceLoader$LazyIterator.nextService(ServiceLoader.java:376) ~[?:?]

	at java.util.ServiceLoader$LazyIterator.next(ServiceLoader.java:404) ~[?:?]

	at java.util.ServiceLoader$1.next(ServiceLoader.java:480) ~[?:?]

	at net.fortuna.ical4j.model.AbstractContentFactory.getFactory(AbstractContentFactory.java:85) ~[?:?]

	at net.fortuna.ical4j.model.PropertyFactoryImpl.createProperty(PropertyFactoryImpl.java:78) ~[?:?]

	at net.fortuna.ical4j.data.CalendarBuilder$ContentHandlerImpl.startProperty(CalendarBuilder.java:326) ~[?:?]

	at net.fortuna.ical4j.data.CalendarParserImpl$PropertyParser.parse(CalendarParserImpl.java:206) ~[?:?]

	at net.fortuna.ical4j.data.CalendarParserImpl$PropertyParser.access$1100(CalendarParserImpl.java:190) ~[?:?]

	at net.fortuna.ical4j.data.CalendarParserImpl$PropertyListParser.parse(CalendarParserImpl.java:173) ~[?:?]

	at net.fortuna.ical4j.data.CalendarParserImpl.parse(CalendarParserImpl.java:122) ~[?:?]

	at net.fortuna.ical4j.data.CalendarBuilder.build(CalendarBuilder.java:198) ~[?:?]

	at org.openhab.io.caldav.internal.job.EventReloaderJob.loadEvents(EventReloaderJob.java:339) ~[?:?]

	at org.openhab.io.caldav.internal.job.EventReloaderJob.loadEvents(EventReloaderJob.java:320) ~[?:?]

	at org.openhab.io.caldav.internal.job.EventReloaderJob.execute(EventReloaderJob.java:137) ~[?:?]

	at org.quartz.core.JobRunShell.run(JobRunShell.java:202) ~[?:?]

	... 1 more

Also, I don’t know how I could delete my old calendars which don’t work now. I have deleted from the .cfg file, but I can still see that reload job scheduled for ‘old calendar’ and I also get these exceptions for them too.

I don’t know about the new error, did you you change anything? Update?

Did you clear the cache?

I just wanted to add a new calendar. However this binding always worked very periodically for me.
I will try to clear the cache, but I’m afraid because every time I have cleared my cache, it caused a bigger error :sweat_smile:

I still have the same problems, thought I have deleted the cache.

However I have enabled debug logging for this binding and it says:

2018-10-22 18:21:02.535 [DEBUG] [caldav.internal.job.EventReloaderJob] - loading events from file : etc/caldav/dinner/467lom4857aXXXXXXXXXX_google_com.ics

2018-10-22 18:21:02.540 [WARN ] [caldav.internal.job.EventReloaderJob] - Cannot load events

However I don’t even have a caldav folder in the /etc folder.

Ps.: I have found it in /var/lib/openhab/etc
I have all my ics files there, don’t know what is the problem. I also get errors next to the file when loading like this one: FSchangedTS not valid
Also, clearing the cache won’t help, old calendars are still there. Tried clearing all folders in the /caldav folder, but that won’t help also.

So now it seems that all of my calendars are configured properly, because it is working, but only one at a time. So I have 3 calendars and after a restart only one of them are displaying events. Every calendar has events so it is not the problem. I for example had an upcoming event in one of my google calendars which will happen 7 days later. Today I restarted openHab, this event is gone, now I can see my icloud events…

I’m still having this issue on final 2.4

I don’t think that this is a configuration error, because all of my calendars sometimes works (but mostly not…).
Investigating the problem, it seems that if I refresh the corresponding calendar.items file, the events gets published to the items.

Any solution?

Logs? Configs?

Sorry for not letting know but there were no errors… However I think I have found my config error. I have only configed caldavio.cfg, but my caldavpersonal.cfg was empty. After adding usedCalendars to caldavPersonal, now it seems to work even after a reboot (when before it usually disappered).