[SOLVED] Cannot access KARAF console any more

  • Platform information: openHABian 2.3.0


suddenly, I cannot access the KARAF console any more using

$ sudo ssh openhab@localhost -p 8101
[sudo] password for openhabian:

After entering the password, nothing happens any more, as if the port is just not responding.

After a while, I get

Received disconnect from port 8101:2: Session has timed out waiting for authentication after 120000 ms.
Disconnected from port 8101

A reboot did not change things. I applied this fix shortly before, but I cannot imagine that it could have something to do with it.

Google was not helpful.

Any ideas? Please?

You are using a “sudo” command to get to the karaf console, why?
That way you need the password for the user openhabian AND thereafter the password for the console.

I’m not sure why. I found that somewhere in the docs. However, with or without sudo, it did not make a difference.

BUT now, after returning from lunch, I tried again (using exactly the same command), and suddenly it works again. I’m baffled.

I guess I took the sudo from this openHAB 2 configuration tutorial. But it does not explain why to use sudo.

Does openhab-cli console produce the same result?

I’ve learned that, for some reason unknown to me, it does no work any more with localhost, but it does work with