[SOLVED] Can't connect to LG webos 4.7


I’ve installed the LG WebOs Binding via Paper UI, but I can’t connect my LG tv with the auto discovery and I thing I’m doing something wrong connecting it manually.
My webos is version 4.7.

Could you give me some hint?


Any errors in the log?
WHat does the paperUI show?

Again, it may help if you shared what you are doing… Including error logs

Not with so little information
Did your read this?

I’ve followed this wiki with the following configuration, set my IP

Based on this comment

I’ve entered into the expert mode configuration on the binding and added the host and as a key I’ve used the ip of the tv, with no luck. As the comment says I don’t have to set the ip there, but I don’t know where to find that “secret key”.

About the logs I just can see that the binding has been installed, nothing saying that a connection is done, TV found or anything related with WebOs.

Any Idea?
Thanks for your help.

The “secret key” should be in a file like the secret key for opencloud on OH is located at /var/lib/openhab2/openhabcloud/secret. This doesn’t answer your question but hopefully points you in the right direction. Also check the links below for additional info that may help.




use upnp discovery, it will make the process effortless

if you have multiple network interfaces you may have to set the system interface in openhab‘s system network settings for upnp discovery to work

host is the IP or hostname of your TV and will automatically be set if you use upnp. otherwise set it manually to circumvent automatic discovery

key is necessary in a second step to pair the device. you will be prompted on the tv to approve the pairing. once done the key should be visible in properties on paper ui thing details.



Thanks all for your help.
I got the tv connected but I don’t know how.
I guess as Sebastian said it connected when I put the pair host and ip in the binding.

The switch on wasn’t working, but since I installed the WOL binding and configure it properly now everything woks like a charm.

Thanks for all this effort :smiley: