Solved -- Can't initialize Everspring SF812 in openhab / in openzwave works

I have searched all over so I apologize if I have missed someplace where
I can find the answer to this.
Found Post Inclusion of ZWave Everspring SF812 smoke-detector /w habmin but the description does not solve my problem.

I did the inclusion process of my zwave devices in openzwave (everything went fine in only 10 minutes).
Afterwards I started openhab 1.7.1
Result: Node3 has a grey icon in habmin
Next step was to wake up SF812 manually (close to the ZWave Controller).
See the result in screenshot below:

It is very interessting for me, that I receive an event after pushin the TAMPER Button, but on the end of the message is “Transaction not complete: node address inconsistent”

What steps has to be done, for a correct Transaction ?

See the delivered information from openzwave below:

Take a look here and also read these links in one of my posts.

Edit: Sorry, didn’t follow your links … you already found that post :sunglasses:

Second Edit: I also tried to make the SF812 work with openzwave: no success either. At Xmas I hopefully get a new smoke sensor and then I will kick that Everspring down the hallway …

Hi sihui,
did you solve your problem ?
For me it is not clear, what to do :frowning:

I steped back to openhab 1.6.2 with org.openhab.binding-zwave.1.6.2.jar and everything works fine.
I think there is a bug in 1.7.1.
If you need some information, I can send you the logs.

Found the same behavior in Post

[quote=“wl12, post:4, topic:5175, full:true”]
did you solve your problem ?[/quote]

No, the device still shows gray in habmin, doesn’t report tamper and battery, but the smoke alarm gives me a open/closed in OH when the test button is pushed.

Is this still an issue with the latest nightly 1.8 snapshot build of the binding from cloudbees?

I’m on a slightly older 1.8 snapshot (, same issue.
Do you have any indication that it should work with the newest snapshot?
Then I may try it …

nope none at all :smile:

I really cannot believe it: tried the newest snapshot and the SF812 turned green!

This is normal - it’s a debug message, not an error.

Please ensure that you wake the device up a couple of times at least, while it is close to the controller to allow the binding to initialise the device for the first time…

If it’s still not working, please provide a logfile and I will take a look.

Thanks to richbeales
With the latest nightly build of openhab 1.8.0 everything went fine :smile:

1 Like