[SOLVED] Can't remove thing from astro binding

how can I get rid of a formerly created and not more needed thing from astro binding. I once created the thing within my default.things file and later deleted it form there.

astro:sun:min60 [ geolocation="53.141020,2.643553", altitude=100, interval=60 ]

Now I relasied that the same thing still appears in Paper-UI. I tried to get rid of it by clicking the dust bin, but Paper-UI reports “ERROR: 409 - Conflict”. I put the thing back into my default.things file and again tried to remove it from Paper-UI, but with the same error.

Hello @FrankR Things, Items, Sitemaps etc. created in a File can not be deleted or edited via PaperUI.

Take a look at this http://docs.openhab.org/configuration/index.html#comparison

Hello @BrutalBirdie, thanks for pointing me to that overview. I still do not see how I can get rid of the thing

sorry did not reed that correctly. You can try this ref link

or you edit the json.db file and delete it manual. BUT you need to shutdown openHAB first before editing the json.db
The jsondb is located here openhab2/userdata/jsondb and the file org.eclipse.smarthome.core.thing.Thing.json contains your things

1 Like

Or from Karaf:

smarthome:things remove astro:sun:min60

it should work

1 Like

Doesn’t work. karaf replies: Could not delete thing astro:sun:min60.
So, maybe I will try to edit the db. is it a simple file or do I need sql?

what does karaf say when you ask it to list all the things?
Does the “problematic” one appear in the list?

smarthome:things list

It’s a simple json formatted flat text file.
In my system, it is located in /var/lib/openhab2/jsondb/org.eclipse.smarthome.core.thing.Thing.json

yes it appears: astro:sun:min30 (Type=Thing, Status=ONLINE, Label=Astro sun data, Bridge=null)

30 or 60 ? :slight_smile:

smarthome:things remove astro:sun:min30

I have both :wink: and both can’t be removed

Well… if you think about it… that’s normal
If we could remove the Sun… we would be all in a big, big trouble! :stuck_out_tongue:

1 Like

oh, sh*t, I forgot about that. Glad you mentioned this :wink: Maybe I should try to remove the moon first :joy:

1 Like

Mine is located in the same path. But there is nothing in there which matches “astro” or “sun” or “min30” or “min60”

can you restart the OH2 service?
It should go away after that…

I did and the things are gone. Sometime it’s just too simple :wink:

1 Like