[SOLVED] Chart generation failed: null

now, I do see *.rdd files in userdata/persistence. each one with 116.408 Bytes

Unfortunately I don’t get any data with the rest service but this is probably user error since I don’t get data on the other machine with working charts as well.
Querying the api for persistence service “rrd4j” returns no items on both machines.

the fontconfig sounds likely, Synology DSM seems to do some things differently than the common linux distro :frowning:

Looking into moving this to the raspberry now

In this case you are doing something wrong. If you want help on that please post the used command (REST API does show the CURL command). The size of the rrd file is set when starting the service for this item, it doesn’t say anything about the content.
I suggested this link because this error did popup a couple of times in the last week’s.

Ok, got the REST call working and there is indeed data stored in rrd4j

{“name”:“ap17_sensor_2_temp”,“datapoints”:“360”,“data”:[{“time”:1567701840000,“state”:“23.75”}, etc

Now, with that verified I tried one more thing

/rrdchart.png?itemsap17_sensor_2_temp?serviceId=rrd4j&period=h

and I get

java.lang.NoClassDefFoundError: Could not initialize class org.rrd4j.graph.RrdGraphConstants at org.rrd4j.graph.RrdGraphDef.<init>(RrdGraphDef.java:80) at org.openhab.persistence.rrd4j.internal.charts.RRD4jChartServlet.createChart(RRD4jChartServlet.java:257)

I think I saw a line mentioning font stuff somewhere but cannot see it anymore.

Since I don’t want to mess up the Diskstation I’m going Raspberry now

thanks

Have a look Here.

Edit: The posted link was not correct, corrected it!

I think I found the solution to my “no charts in openhab on synology” issue:

export FONTCONFIG_PATH=/opt/etc/fonts/

Synology/DSM doesn’t seem to come with proper font stuff out of the box. But It is possible to install additional linux programs and libraries into /opt via OptWare/IPackge or whatever.
Then download the Dejavu font package that rrd4j seems to rely on and add that to fontconfig. Finally make the fontconfig available via the export. Now run openhab (via the karaf script) and - horray - charts get get generated! WOHOOOO

unfortunately, right after this discovery I lost access to the Diskstation at the remote location and can finalize this only in a couple weeks, sigh

Nevertheless I’m playing here with a Raspberry. Where I run into other issues. OH2 Exec and regex result parsing, anybody?

Regards

I’m glad, you a solution.
On that:

Please open a separate thread with a meaningful topic, otherwise the chances of getting help are neglectable.