[SOLVED] Closed: My openhab is offline in myopenhab.org

Dear experts,

since a couple of days, I cannot connect to my openhab running on raspberry via myopenhab.org. The following message is shown after login:

" Your openHAB is not online. Please check if your installation is running or recheck the openHAB settings in your account."

Actually this problem seems to exist since 11.06.2019:

I checked my openhab.log and found these entries:

2019-06-19 20:09:22.008 [INFO ] [io.openhabcloud.internal.CloudClient] - Shutting down openHAB Cloud service connection
2019-06-19 20:09:22.039 [ERROR] [io.socket.thread.EventThread        ] - Task threw exception
java.lang.NoClassDefFoundError: okhttp3/Call$Factory
    at io.socket.client.Manager$1.run(Manager.java:277) ~[?:?]
    at io.socket.thread.EventThread.exec(EventThread.java:55) ~[282:io.socket.engine.io-client:1.0.0]
    at io.socket.client.Manager.open(Manager.java:266) ~[?:?]
    at io.socket.client.Manager.open(Manager.java:256) ~[?:?]
    at io.socket.client.Socket$3.run(Socket.java:142) ~[?:?]
    at io.socket.thread.EventThread$2.run(EventThread.java:80) [282:io.socket.engine.io-client:1.0.0]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
    at java.lang.Thread.run(Thread.java:748) [?:?]
Caused by: java.lang.ClassNotFoundException: okhttp3.Call$Factory cannot be found by io.socket.engine.io-client_1.0.0
    at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:484) ~[?:?]
    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:395) ~[?:?]
    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:387) ~[?:?]
    at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:150) ~[?:?]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:?]
    ... 9 more

I’m running openHAB 2.5.0 Build #1616 and tried some others during the last days. Also restart of openhab has been done several times as well ad uninstalling and installing Openhab Cloud Connector Add on via Paper UI.

Does anyone have a similar issue? Can someone help?

Many thanks.


It’ll be fixed when you update to build #1617 or newer, see:

1 Like

yes, I installed openHAB 2.5.0 Build #1619 and it’s online again!

1 Like