(Solved) Conbee 2 and Openhab 3 - Cannot reach Conbee

Hi guys,
I’m a newbie, but a I have read every topic about Conbee 2. Unfortunately, I have not yet solved my problem: I cannot access (nor use) the Conbee 2 when it is connected to my Raspberry 4 (USB 2.0) with Openhab 3.0.1

If I connect the Conbee 2 to my Windows 10 PC, I can reach the webpage of Conbee 2.

In Openhab I installed these :

  • Dresden Elektronik deCONZ Binding
  • Hue Binding (I’m trying to connect the Philips Discover 'Floodlight" Hue by Zigbee Protocol, without Hue Bridge)

I followed this guide with SSH and PUTTY: ConBee II Installation

But when I try to login using [RASPBERRYIPADRESS:80], my browser cannot find any pages.

On the other hand, when I plug my Conbee 2 into the PC, Openhab finds two new things in my INBOX :

  1. Phoscon-GW (deconz:deconz)
  2. Phoscon-GW (hue:bridge)

The concern is that if I add these two things they will no longer work when I disconnect the Conbee 2 from my PC because the IP of the PC is tied to the Conbee 2.

In other words, when I plug the Conbee 2 into the raspbery, it cannot find both things and I can’t reach the webpage.

I don’t know what I’m doing wrong …? Does anyone have a hint for me?

Mine works on port 8090

Not your issue, but there should be no need to use the Hue binding.

1 Like

Just tried it, but it’s not working :frowning:

Thanks for your help :slight_smile:

Did you install the deconz software on the raspi? And are you sure it is running?

Mmmmh, I’m not sure actually.

I imagine you’re not referring to the installation (ConBee II Installation) I mentioned in my first post?

If something else needs to be done, then no. What did I forget?

Yes that software. The question is if it is running. And if it properly connects to the stick. Maybe you can check with ps ax | grep -i deconz if a process is running:

pi@phoscon:~ $ ps ax | grep -i deconz
  354 ?        Ss    39:39 /bin/bash /usr/bin/deCONZ-update2.sh
  371 ?        Ss   114:50 /bin/bash /usr/bin/deCONZ-WIFI2.sh
 1240 ?        Ssl  942:36 /usr/bin/deCONZ --http-port=80
 1812 pts/0    S+     0:00 grep --color=auto -i deconz

That’s what is running on my gateway (I have a RaspBee though, not a ConBee, but that should be the same software).

I got that :

[17:16:13] XXX@XXX:/home/XXX# ps ax | grep -i deconz
16400 ?        Ss     3:04 /bin/bash /usr/bin/deCONZ-update2.sh
28681 pts/0    S+     0:00 grep --color=auto -i deconz

Then it’s not running. Try to start it and see what happens.

If it does not startup, I guess there is a log somewhere. Not sure where.

Edit: You can also try another port like 8090 in case 80 is already in use. openHAB itself uses 8080, so that’s not a good choice.

/usr/bin/deCONZ --http-port=80
qt.qpa.screen: QXcbConnection: Could not connect to display
Could not connect to any X display.

[17:23:44] root@openhabian:/# /usr/bin/deCONZ --http-port=8090
qt.qpa.screen: QXcbConnection: Could not connect to display
Could not connect to any X display.

Must I connect a monitor ? :sweat_smile:

Really thanks for your help, I appreciate a lot.

Thank you. I will install VNC and try this :slight_smile:

The importnat thing is that you start the X server on the Pi.

3 hours I’m on it, and I’m stuck.

I’m trying to login to GUI but when I tried openhabian:openhabian :

About “start the X server”, I tried the command “startx” but nothing happen :

openhabian@openhabian:~ $ startx
-bash: startx: command not found

Unfortunately I can‘t help you there. I used a dedicated Pi with the image provided by deconz.

Thanks anyway for your help :slightly_smiling_face:

I installed a GUI (Pixel) and got this :

openhabian@openhabian:~ $ ps ax | grep -i deconz
  373 ?        Ssl    0:04 /usr/bin/deCONZ -platform minimal --http-port=80
  374 ?        Ss     0:00 /bin/bash /usr/bin/deCONZ-update2.sh
  385 ?        Ss     0:00 /bin/bash /usr/bin/deCONZ-WIFI2.sh
 4211 pts/1    S+     0:00 grep --color=auto -i deconz

… buuuut Openhab is not responding anymore :sweat_smile:

I’m gonna erase my SD card and do a fresh install :slight_smile:

Solved thanks to this topic : Phoscon/deCONZ on openHABian - #3 by HannesFE