[SOLVED] Configuration Parameters menu missing from Z-wave device in HABmin - Remotec ZTS-500

anyhow fellas… I am almost positive Chris uncovered a buggy and fixed missing parameters in Habmin & Paper UI if not mistaken, but I am talking days ago so probably no merged yet or only in bleeding edge snapshot.

He is also still struggling to get a development environment going I think

ummmm… this might be a good use for Scott’s install script???
never used but maybe somebody chime in??

check out this thread for zwave install script which may help you get an upgraded zwave binding going. Read the instructions and info in this thread

I don’t know if an upgrade of OpenHAB is going to be neccesary. I am running OpenHAB stable 2.4 and a zwave snapshot

I am running 2.5M1 with a snapshot zwave binding installed using the script. I seem to recall somebody trying a snapshot binding on 2.4 and having issues until they upgraded to 2.5M1.

Thanks, I will.

I grabbed the 2.5 snapshot from a modified link supplied by Chris in another post. Then installed the binding and followed the instructions here. I also had to manually install the transport-serial package (this step is probably included in that script, to which @Andrew_Rowe pointed me).

But after install, the menu for the device’s configuration parameters is still not displayed. Also I see the date for the binding shown as:

openhab> bundle:list | grep ZWave
270 x Active   x  80 x     x ZWave Binding

The Jan 20, 2019 date matches the release on Github for 2.5.0.M1. So am I correct in assuming that the link Chris supplies is for the official release that he uploads to his site only for major revisions?

Since @sihui and @Bruce_Osborne pointed out that the database file for the device in question was updated after this (2019.03.12), this means I need to be building the latest from source, or using the install script.

I’ll report back when I’ve tried one. I might install an IDE and attempt to build myself, since I have other bindings that also provide daily updates, and it would be nice to be able to build all of these at will.

Don’t make it too complicated, just grab the latest from here:



The readme for the script has instructions for doing everything manually, including a URL for the latest snapshot of the binding. The link you used should be removed… it was used for testing. This is actually an option in the script too (the development option), since Chris sometimes provides builds for people to test.

Instructions for xstream are in there too! :wink:

1 Like

hits Bookmark button eighteen times

Perfect! I did not know this existed, thank you very much. Might I recommend that link be added to the zwave binding README on the Github front page? It might help others find the latest *.jar file.

Thanks for the tips. Which link?

Also, delete all your zwave Things & rediscover them.

This one:

This is not just a download page for the zwave binding, but also for the whole openHAB project, therefore you can find that link in the docs:

Snapshot: Benefit from the latest changes in the daily created snapshot (hosted on openhab.org).


Ah, oops. I’ll keep my recommendations to myself… :relaxed:

This one (Chris would have to remove it from his post)…

Upgrading to the latest Zwave binding snapshot did the trick. Configuration Parameters show up and can be updated via HABmin.

Many thanks for everyone’s help!


good catch Bruce
and also glad to see the parameters buggy squashed
@Diogenes please update the title of thread with [SOLVED] and put a check box in the post that helped you solve the problem (you did a lot yourself - good on you)

oh and @Diogenes additional question:
did you upgrade your OpenHAB version or just your zwave binding version?

yeah but issue was most probably because of transport serial package not installing which Diogenes was slick enough to pick up on his own
just curious
I am still on stable 2.4 but running a jar zwave, I way try the latest just to see if works

Just the binding, using the latest snapshot from the openhab website:


awesome and great job

Before making statements like this

I would recommend at least pre-qualifying this statement with 'if this is not a production installation ’ or some such before authoritatively recommending an upgrade of the entire platform from a stable version. People may be relying on things not breaking and an unneccasary upgrade could cause untold troubles.

see… not needed

update of OpenHAB is NOT needed!!!