[SOLVED] Confusion about item/sitemap storage in different UIs

Dear all,

I’m currently playing around with my first OpenHAB installation on a Pi3. In PaperUI everything is beautiful and running nicely.

No I try to setup my first BasicUI. Somehow, there is some ghost in the system: I copied some examples from the web for creating groups and items. This worked well. After that, I erased them again.

Still, the system seems to remember these groups: If I display a group called “Bathroom” in the BasicUI, it remembers some former test where I associated a power plug to that group. I deleted i hours ago, but still this seems to be stored somewhere. Note, I rebooted the Pi, I checked if changes in the files I edit lead to changes in BasicUI (they do) so I’m working on the right ones.

Additionally, HABmin shows all these old items and groups as well but I cannot see where it still finds them.

Please help - thanks

I noted this too. What I learned that the current V2 is a mix of different components which have not evolved from one previous version but are simply “stacked” together. The HabPanel uses a hidden(?) internal database for items, bindings…etc whereas the old BasicUI is using the text file settings as described in the documentation.

“Somehow” this in linked and synchronised but I have to leave it to the experts to explain that…?

Have you tried to delete the contents of the cashe and tmp files?

If not, use the following from the command line to do so:

openhab-cli stop

openhab-cli clean-cache

openhab-cli start

This should remove any item that’s been created then deleted from your OH files.

I thought this got fixed but perhaps not or your are running a version before the fix.

There was a big where some changes to Group membership do not get picked up until after a restart of OH. Have you restarted and are the Groups still messed up?

My software installation is 10 days old, so I would assume it is recent.

I rebooted 3 times whic did not help.

Now I removed all groups and items in HABmin which seems to help.

Thanks for your clarification :slight_smile:

when you go http://local adres: port/start/index
at the bottem you see the openhab version.

something like openHAB 2.4.0 Milestone Build

It is openHAB 2.3.0-1 (Release Build)

When you installed is less important than what you installed and how you installed it. For example, if you are running the latest release you are running on OH 2.3 which is nearing six months old. If you are running the milestone version you are running MY which is a week it so old at this point. If you are running the snapshot you are running everything added to the code to to yesterday.

I don’t remember if there group membership problem was fixed before or after the 2.3 release. Six months is an eternity at the current one of OH development.

You might consider using the milestone versions for now. These get created one a month and are relatively bug free.

If this is some problem with habpanal I won’t be much further help.

And in addition to above post, if you would like to upgrade to Milestone builds, here is how to do it:

Choose testing releases.

1 Like


That did it :slight_smile:

1 Like

Good to hear it’s working.

Please mark the post solved by clicking on the square box, inside the post, that provided the solution.



1 Like