[SOLVED] Creating binding - debugging OSGI fails

I’m am creating a new binding. Yesterday everything worked perfect but overnight something changed.
The Eclipse IDE started building all the bindings and whet I debug OSGI

Status ERROR: bndtools.core code=0 Cannot find /error/org.openhab.binding.qbus;version=[2.5.0,2.5.1) Not found in [bndtools.m2e.MavenImplicitProjectRepository@55feec23, bnd-cache [C:/Users/ks/.bnd/default-ws/cnf/cache/4.2.0/bnd-cache r/w=false]] null


Status ERROR: bndtools.core code=0 org.openhab.binding.qbus;version=[2.5.0,2.5.1) Not found in [bndtools.m2e.MavenImplicitProjectRepository@55feec23, bnd-cache [C:/Users/ks/.bnd/default-ws/cnf/cache/4.2.0/bnd-cache r/w=false]] null

When I continue my binding doesn’t shows up in paper UI.

Can somebody explain me what happens and what i can do to fix this?

PS I’m running this version: Version: 2019-03 (4.11.0) because the newest version doesn’t seem to work.

I don’t know why it’s not working. What can help is to close all bindings you have in eclipse that you don’t work on. Also instead of have the dependency on the openhab2-addons in the pom.xml of the demo project replace it with the dependencies of the projects you want to work on.

I’m wondering if the problem is the bom-pom. If you add something to the bom and later a new version is downloaded from the remote repo it might be that your newly added binding is missing (didn’t verify, just guessing). Can you check if your binding is still in


And if it is not, try running

mvn clean install -pl bom\openhab-addons

and see if it present afterwards. If it is, try running.

Thanks for the reply and advice guys!

I checked this file:
Cause i don’t have the other file on my system, and my binding is still present.

I did a clean install to be sure, but still the same errors occur.

I don’t have any other bindings open, just the project i am working on. And i’m not using the demo project.

Another thing that i find strange. I thought that yesterday the demo project was on top of the list and now it is just between the openhab2 addons.

I think that i have found the problem, but it is strange that it only occurs now.
The ks folder is only available when i’m t the office, yesterday and today i work on the project at home.
We’ll see on monday if that fixes it.
Still don’t get why everything went well yesterday.

Edit: I’m doing a clean install right now, i keep you informed if i can continue programming then.

You sure have a .m2 repository somewhere. Maven automatically creates that. This is different from your git repository. The directory usually is in your home directory and hidden.

You are right, i found the file and added my project.
But when i run the given command i get this error:
[ERROR] Could not find the selected project in the reactor: bom\openhab-addons @

Thanks for helping me out man, i really appreciate it!!!

Where do you run that command? You should NOT edit the .m2-file, just check if your bundle is present. Then run the command in your git repository. The .m2 should be updated afterwards automatically.

Thanks a million man, you where right on the spot from your first reply.
Don’t now how to thank you !!!

1 Like

can you share how to export package from your custom binding? Previous build system could simply edit MANISFEST.MD to export whatever, but the new one seems hidden somewhere which i can’t find. Thnaks!