[SOLVED] Custom Binding won't send HTTP Requests

Tags: #<Tag:0x00007fc3ec4f36b8>

So I put together a server/system similar to philips hue to control my led strips and add functions I want.
After I came across openHAB I was wondering if I could write my own binding/add-on for it, so I set up Eclipse etc…

After all I was able to test my custom binding with the test environment coming with the ide installation and it works flawlessly. However if I try to use it with a regular installation of openHABian and it just won’t send any HTTP Requests what so ever… I even went so far and copied some code from the WeMo Binding but no luck.

Maybe someone has a hint or something

Nice you build your own binding. To help you we need some more information. Did you seen anything in the logs? And do you have your code somewhere online? Because otherwise it will be very much a guessing game what could be wrong. For example: do you know if it doesn’t send or if the calls never reach your devices?

I didn’t see any errors what so ever, just normal stuff regarding the binding, like state changes etc.
As mentioned above, the binding worked perfectly fine in the test environment, my server got the http request and the binding was able to receive responses as well.

I just uploaded the whole binding folder to GitHub, have a look if you want. (not the best code you have seen for sure, but it worked) :smiley:

You might what to start by adding a log statement to this part of the code :smile:

        } catch (Exception e) {

        } 

Also maybe use class org.eclipse.smarthome.io.net.http.HttpUtil to make calls (Search for this class on the openHAB2-Addons repo to get some examples)

I feal so tricked right now… I had to reinstall my eclipse ide setup because I had problems with the test environment and what did I do? Compile the old binding project over and over again.

It works perfectly fine, I just added the wrong jar to the addons folder.

Well, going to delete the old setup so it won’t happen again. Never the less I already changed the empty catches and changed my http library to the mentioned one, so I was wondering why you came up with that and then I noticed I uploaded the wrong folder…

Even though that wasn’t the sollution, thanks anyways!