[SOLVED] Cyrus Water Sensor and Z-Wave not recognized

Hello @chris,

I’m trying to get a Cyrus flood sensor (https://www.notebooksbilliger.de/cyrus+smarthome+flood+sensor+z+wave+plus) to work with OpenHAB, but I do not manage to get it properly included. I assume that it’s not in the database, but I have no clue how to add it as I do not get any kind of ID or any information from it. Please see the following screenshot:

So it seems to me properly discovered and included in the Z-Wave network, but just unknown. However, to add it to the database I assume I need the vendor (Hersteller) and device id (Typ-Kennzeichen) which I do not have.

I have tried to wake up the device several times and also removed and added it again but no luck. Do you have any suggestion?

Thanks and cheers!

Even though if it is not in the database you should be able to properly include it.
I would exclude it, reset the device and try to include it again until a node.xml file is created.
It looks like some of the Cyrus devices are from manufacturer Shenzhen, so you may be able to identify it in the database:

Hi @sihui

thanks for your reply. I tried inclusion / reset / inclusion / … a couple of times but unfortunately no luck with it, yet. The max is that it is not called “Node” but “Z-Wave Node” in OpenHAB and as I showed in the screenshot.

I might give it a try in Domoticz to see whether it’s gonna be recognized there and if it is, so to get more information about the device and hopefully get it then successfully included in OpenHAB.

Did you check for any *.xml files yet?

Are you sure it’s really waking up? I don’t see a wakeup time in the attributes that I would have expected (I think). What do the logs show is happening?

Why is this a problem?

@sihui Yeah - I checked and there’s no node27.xml file.

@chris No - it’s not a problem, but I just said it’s the maximum achievement I had. The log says this:

/var/log/openhab2/openhab.log:2017-10-08 10:42:27.472 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 27: Device discovery could not resolve to a thingType! 7FFFFFFF:7FFFFFFF:7FFFFFFF::0.0
/var/log/openhab2/openhab.log:2017-10-08 14:07:31.484 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 27: Node found
/var/log/openhab2/openhab.log:2017-10-08 14:15:57.684 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 27: Node found
/var/log/openhab2/openhab.log:2017-10-09 12:52:36.492 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 27: Node found

I’ll put into TRACE mode to see what it’s gonna say then.


The TRACE says:

16:44:40.681 [DEBUG] [essage.ApplicationCommandMessageClass] - NODE 27: Transaction not completed: node address inconsistent.  lastSent=27, incoming=255
16:44:40.775 [TRACE] [ZWaveSerialHandler$ZWaveReceiveThread] - Received SOF
16:44:40.776 [DEBUG] [ZWaveSerialHandler$ZWaveReceiveThread] - Receive Message = 01 14 00 04 00 0A 0E 32 02 21 74 00 0F 19 12 00 00 00 00 00 00 8A
16:44:40.776 [TRACE] [zwave.internal.protocol.SerialMessage] - NODE 255: Creating new SerialMessage from buffer = 01 14 00 04 00 0A 0E 32 02 21 74 00 0F 19 12 00 00 00 00 00 00 8A
16:44:40.777 [TRACE] [zwave.internal.protocol.SerialMessage] - Calculated checksum = 0x8A
16:44:40.777 [TRACE] [zwave.internal.protocol.SerialMessage] - NODE 255: Checksum matched
16:44:40.777 [TRACE] [zwave.internal.protocol.SerialMessage] - NODE 255: Message payload = 00 0A 0E 32 02 21 74 00 0F 19 12 00 00 00 00 00 00
16:44:40.777 [TRACE] [ZWaveSerialHandler$ZWaveReceiveThread] - Message is valid, sending ACK
16:44:40.777 [TRACE] [ZWaveSerialHandler$ZWaveReceiveThread] - Response SENT
16:44:40.777 [DEBUG] [ave.internal.protocol.ZWaveController] - Receive queue TAKE: Length=0
16:44:40.778 [TRACE] [zwave.internal.protocol.SerialMessage] - Calculated checksum = 0x8A
16:44:40.778 [DEBUG] [zwave.internal.protocol.SerialMessage] - Assembled message buffer = 01 14 00 04 00 0A 0E 32 02 21 74 00 0F 19 12 00 00 00 00 00 00 8A
16:44:40.778 [DEBUG] [ave.internal.protocol.ZWaveController] - Process Message = 01 14 00 04 00 0A 0E 32 02 21 74 00 0F 19 12 00 00 00 00 00 00 8A
16:44:40.778 [DEBUG] [ave.internal.protocol.ZWaveController] - Message: class=ApplicationCommandHandler[0x04], type=Request[0x00], priority=High, dest=255, callback=0, payload=00 0A 0E 32 02 21 74 00 0F 19 12 00 00 00 00 00 00
16:44:40.778 [TRACE] [ave.internal.protocol.ZWaveController] - Incoming Message type = REQUEST
16:44:40.778 [TRACE] [essage.ApplicationCommandMessageClass] - Handle Message Application Command Request

Hello @sihui and @chris once again,

it seems to get closer to working. I still have a “?” at the icon but it’s de-facto recognized as flood sensor. I took the hint to look at the database for Shenzhen devices and figured out that pressing the include button 3 times is the magic way to go (the two devices from Cyrus didn’t come with any manual from which I could have seen that).

Still the questionmark seems to tell it’s not yet working and when I click on device reinitialization I get the following error in the log:

17:00:38.726 [ERROR] [est.core.internal.thing.ThingResource] - Exception during HTTP PUT request for update config at 'things/zwave:device:e94667c8:node29/config' for thing 'zwave:device:e94667c8:node29': Thing with UID zwave:device:e94667c8:node29 has no handler attached.


The HABmin site looks better now:

Okay - after a complete reboot (not just OpenHAB restart) of the machine, it seems that the device is now properly recognized and working.

Thanks guys for your help. The most important one was the info that it’s a Shenzhen device and the database lookup.

1 Like

i have the same device. It is still unknown. Reboot doesent help.
Do i have to import the xml file or something elfse?


Please post the information about your device (ie all the properties as above) so we can evaluate what you actually have. It might be different…

Ok, its online after a few reboots and triple pressing the button, several times. But the trigger doesn’t work.
If its in the water the LED is on, the siren to. But habin says still Untriggered.

Here is the config.